-   Linux - Hardware (
-   -   vid drivers not working how do i go back? (

V_LESTAT 01-20-2004 06:54 PM

vid drivers not working how do i go back?
ok so i installed the firegl 8800 driver when im using the 9700 pro card,, i thought this was suppse to bring out the accelerated hardware,, or at least help in the process.

ok so now bash say it cant initialise kde after doing this

i pray there is a way to go back to the other driver or a different driver or fglrxconfig file ? what ever its called ,, sorry.

can i simply do the config after kde errors out,, then start startx again ? and login and load kde ?? or is there antoher way

oh btw what the hell is the command when logging in thru bash to load Gnome. ?? i know kde loads kde but what about gnome ? cuz i like gnome just as much as kde if not more.

V_LESTAT 01-20-2004 07:50 PM

also i have LTools so i can read and write to linux partitions and drives thru windows,,
i have never heard of this tool until a few days ago ,, i kinda found it by accident. kick ass tool. it says it only reads up to ext2 but it DOES read Ext3 and more.

is there anything i can alter or delete to allow me to get back KDE ? i tried running x86 config and fglrxconfig but still nothing,, kde cant start and it says it cant find the display 0 i told it to use the radeon driver and rebooted but it still says its the firegl. wierd

Daemon187 01-20-2004 08:08 PM

1. What distro R U using
2.did U try recompile the module
3. Please post your XFree86 log.

Nice forum, hi everyone! :D

V_LESTAT 01-20-2004 08:21 PM

suse 9
recompile,, yeah i can do things like that,, uh huh, (sarcasm intended)
uhm how do i do that.

im in ltools right now where can i find the log ill just copy it from there.

Daemon187 01-20-2004 09:52 PM

run startx
then go to /var/log/XFree86.xx.log ,open this file and paste here the last output from the
So, ..................:scratch: .......type lsmod ,copy,paste here,and i go to sleep ,
I think yout fglrx module is not working, but 1st post your XFree86log and lsmod
then we will see it.

V_LESTAT 01-21-2004 09:19 PM

i really have no clue hwat you want out of that log its way to long its 19 pages long when in MS Word.

but here are some important stuff that it says its missing.

(WW) RADEON(0): Failed to set up write-combining range (0xe0000000,0x8000000)
(II) RADEON(0): Wrote: rd=12, fd=145, pd=1
(WW) RADEON(0): Direct rendering not yet supported on Radeon 9500/9700 and newer cards
(II) RADEON(0): Memory manager initialized to (0,0) (1280,8191)
(II) RADEON(0): Reserved area from (0,1024) to (1280,1026)
(II) RADEON(0): Largest offscreen area available: 1280 x 7165
(II) RADEON(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
8x8 mono pattern filled rectangles
Indirect CPU to Screen color expansion
Solid Lines
Scanline Image Writes
Offscreen Pixmaps
Setting up tile and stipple cache:
32 128x128 slots
32 256x256 slots
16 512x512 slots
(II) RADEON(0): Acceleration enabled
(==) RADEON(0): Backing store disabled
(==) RADEON(0): Silken mouse enabled
(II) RADEON(0): Using hardware cursor (scanline 1026)
(II) RADEON(0): Largest offscreen area available: 1280 x 7158
(**) Option "dpms"
(**) RADEON(0): DPMS enabled
(II) RADEON(0): Direct rendering disabled
(==) RandR enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Keyboard "Keyboard[0]" handled by legacy driver
(**) Option "Protocol" "imps/2"
(**) Mouse[1]: Protocol: "imps/2"
(**) Option "CorePointer"
(**) Mouse[1]: Core Pointer
(**) Option "Device" "/dev/mouse"
(**) Mouse[1]: Emulate3Buttons, Emulate3Timeout: 50
(==) Mouse[1]: Buttons: 3
(II) XINPUT: Adding extended input device "Mouse[1]" (type: MOUSE)
(II) Mouse[1]: ps2EnableDataReporting: succeeded
Could not init font path element /usr/X11R6/lib/X11/fonts/local, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/kwintv, removing from list!
Could not init font path element /usr/X11R6/lib/X11/fonts/CID, removing from list!
(II) 3rd Button detected: disabling emulate3Button
(II) RADEON(0): Wrote: rd=2, fd=24, pd=4

it also says earlier in the log that it cant find any of the font files.

very aggrivating at this point im finding myself reloading yet again.

i did reload,, and after reloading i went to update the vid drivers with te ones from ATI and it started telling me a bunch of stuff needed to be removed,, a bunch of Open Office stuff,., which i thought was stupid also some other stuff that i thought was stupid since it was directly related to video ,, anyways,, it starting killing a bunch of stuff and i exited out of the installer hell im reloading again and not even touching hardware video,, screw it,, if its this much b.s. just to get hardware video when it should be working out of the box then screw it,, it isnt worth the trouble i guess.

sorry for the anger,, just a long day of work and a very shitty time after work jacking with linux crap.. ggrrrr.

Daemon187 01-21-2004 10:41 PM

OK, try this
modprobe -r radeon
modprobe -r fglrx
modprobe -r agpgart

Then download the latest firegl_ati drivers from
rpm -Uhv -i --force fglrx-glc22-4.3.0-3.x.x.i586.rpm (if this do not compiled , type /lib/modules/fglrx/build_mod/./ and /lib/modules/fglrx/./

modpobe fglrx
And the last step is making your - fglrxconfig
[offtopic] If you use AMD is important to NOT use agpgart
It can be turned on only if you set mem=nopentium in liloconfig. [offtopic]

V_LESTAT 01-22-2004 06:40 AM

ok ill try that stuff after work,, right now its 0530 and im off to work. thanks for those commands.

V_LESTAT 01-22-2004 08:21 PM

i havent done that stuff yet im too busy doing stuff in windows where i can actually be productive but i rmemeber what killed linux one of the time,, it was those damn firegl drivers....
so which fireGL driver should i download from ATI for it to work with the 9700 pro.

hhmm nice they all have the same driver name excluding the kernel version.
i ran the check thingy but dont recall what it said that will tell me which xfree86 version i have yes ?

;et me rephrase that which firegl card should i install once inside linux there are more than 1 firegl card ya know.

Daemon187 01-22-2004 08:59 PM


All times are GMT -5. The time now is 05:06 AM.