LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 04-14-2006, 06:46 PM   #1
noteventime
Member
 
Registered: Mar 2005
Location: a small planet in the vicinity of Betelgeuse
Distribution: ArchLinux
Posts: 53

Rep: Reputation: 15
Very bad i915gm performance


First, yes I know that this card sucks big time
Anyway, for the last two weeks I've been trying to get this card to do anything then just VERY basic graphics acceleration.
Although the acceleration I get now is quite enough for my normal use, I'm currently trying to learn the OGRE3D graphics engine with which I can't even get the most basic application to work with this card.
I think the main problem is that the drivers doesn't give me any kind of shader capability (correct me if I'm wrong).
I've tried running the OGRE examples in Windows on the same computer where I get decent performance, being a laptop.
I'm currently running Ubuntu dapper drake, well kubuntu to be exact, and glxinfo shows Direct Render: Yes and OpenGL renderer string: Mesa DRI Intel(R) 915GM 20050225.
Maybe using the new alpha MESA drivers with GLSL capability would help. Or should I simply give up and buy myself another computer, sad as this laptop is good otherwise (1.73GHz Pentium M and 1GB RAM).
 
Old 04-16-2006, 07:47 AM   #2
tamoneya
Member
 
Registered: Jan 2005
Location: MA
Distribution: Ubuntu 7.10
Posts: 558

Rep: Reputation: 30
you seem to be on the right track. New drivers might get it to work and it is not difficult to try so i would go for that. Beyond that i owuld probably recommend you go for a new card because they arent that expensive and it will be worth it if you want to get into graphics engines anyways. It will make your life much easier in the loing run.
 
Old 04-16-2006, 02:10 PM   #3
noteventime
Member
 
Registered: Mar 2005
Location: a small planet in the vicinity of Betelgeuse
Distribution: ArchLinux
Posts: 53

Original Poster
Rep: Reputation: 15
I would get a new card if it wasn't a laptop
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone use a DWL-AG530? getting bad performance hedpe Linux - Wireless Networking 0 03-10-2006 05:32 PM
Athlon xp 2004+ bad performance Doktor Prokt Linux - Hardware 11 05-22-2005 08:22 AM
2 NIC`s activated = bad performance saavik Linux - Networking 3 04-06-2005 06:32 AM
Bad UT2004 Performance with ATI csfalcon Linux - Hardware 1 01-11-2005 02:52 PM
bad 3D performance with geforce 2 on redhat7.1 petez5 Linux - Hardware 0 03-02-2004 02:24 PM


All times are GMT -5. The time now is 04:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration