LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-09-2003, 05:26 PM   #1
bird
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Rep: Reputation: 0
using Redhat 9: Please Translate this readme into n00bish


Hi, i am the king of n00bs, and right now im using redhat 9. Im trying to install this sound driver but i cant understand what to do. Here is the read me, can someone give me some EASY instructions on what to do????



Quick install
=============

1) You must have full configured source for the Linux kernel which you
want to use for the ALSA drivers. Note that ALSA drivers are part
of the kernel, so there is necessary to resolve all symbol dependencies
between the used kernel and ALSA driver code. Partly installed kernels
(for example from distributor makers) can be unuseable for this action.
2) You must turn on sound support (soundcore module).
3) Run './configure' script.
If you have ISA Plug & Play soundcard, use --with-isapnp=yes switch.
If you want sequencer support, use --with-sequencer=yes switch.
If you do not want OSS/Free emulation, use --with-oss=no switch.
If you want turn on debug mode use --with-debug=full switch.
If you want debug soundcard detection try --with-debug=detect switch.
If you have kernel source code in another directory than /usr/src/linux,
use --with-kernel=<kernel_directory>.
Example: ./configure --with-isapnp=yes --with-debug=full
4) Run 'make install'.
5) Run the './snddevices' script to create new sound devices in /dev directory.
Skip this step, if you have a kernel with the DEVFS support.
6) Edit your /etc/modules.conf (see the kmod support section below).
7) Run 'modprobe snd-xxxx' where xxxx is the name of your card.
Note: If you have a ISA PnP soundcard you need to first run the isapnp
program from isapnptools package to initialize your
soundcard. You can also use the native ISA PnP support by
using the --with-isapnp=yes configuration switch, in which
case you do not need the isapnptools package.

You can also look at the utils/alsasound file. This script is designed for
the RedHat distribution, but it can be used with other distributions which
use System V style rc init scripts.

Note: All mixer channels are muted by default. You must use a native
or OSS mixer program to unmute appropriate channels (for example a
mixer from the alsa-utils package).

Note: This document notices the /etc/modules.conf file. Many current
distributions uses the old /etc/conf.modules file. Both names are
valid.



AHHH What does it all mean???? Please HELP
 
Old 09-09-2003, 05:36 PM   #2
wapcaplet
LQ Guru
 
Registered: Feb 2003
Location: Colorado Springs, CO
Distribution: Gentoo
Posts: 2,018

Rep: Reputation: 48
My first question is, why are you trying to compile a sound driver? Redhat 9 ought to support just about any sound hardware right out of the box. If your sound is not working, there is probably a much simpler solution Tell us what kind of sound card you have and perhaps we can help out.
 
Old 09-09-2003, 05:57 PM   #3
bird
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Original Poster
Rep: Reputation: 0
its integrated into my motherboard. "SoundMax Itegrated Audio" is the card name. as to why im trying to compile a sound driver, i DONT KNOW . i just saw a readme on the driver cd so i posted it.
 
Old 09-09-2003, 07:23 PM   #4
nakkaya
LQ Guru
 
Registered: Jan 2003
Location: Turkey&USA
Distribution: Emacs and linux is its device driver(Slackware,redhat)
Posts: 1,398

Rep: Reputation: 45
did you try sndconfig ? go to terminal and type snd config it should find and configure it if you do not have it download it from rhn.redhat.com
 
Old 09-09-2003, 07:37 PM   #5
Eqwatz
Member
 
Registered: May 2003
Distribution: Slack Puppy Debian DSL--at the moment.
Posts: 341

Rep: Reputation: 30
google.com/linux the name of that "sound card" also check the MB website and look at the individual drivers for that board some times the name of the driver will give you a clue. I personally never heard of "Sound Max".

Did you do lspci ? Is that where you got the sound card name?
 
Old 09-09-2003, 09:33 PM   #6
LordMorgul
Member
 
Registered: Sep 2003
Location: Ca
Distribution: Fedora, RH 7.1-9.0
Posts: 68

Rep: Reputation: 15
Go to the main RedHat menu, to System Settings, to Soundcard Detection.

This utility should be able to initialize your soundcard if RedHat 9 supports it with what is already installed. If you cannot hear anything played out of the card by this utility, then you'll need to install and configure drivers yourself, but check this first.

If you do need to handle drivers yourself, you may need to do some extra reading on the general 'compile and install' process of a typical sound driver in linux. I suggest checking some How-Tos on http://www.tldp.org
 
Old 09-09-2003, 10:23 PM   #7
MattZ
LQ Newbie
 
Registered: Aug 2003
Location: Mississauga, ON, Canada
Distribution: Debian 3.1
Posts: 8

Rep: Reputation: 0
I'm not sure about Red Hat, but I have the same SC, which is basically AC 97. My distribution (Mandrake) detected the card and installed the appropriate drivers but in order to have sound, I (and many other users) had to connect the speakers to either Mic or line-in port. Try that, it should work, and also make sure that everything is unmuted.

Matt
 
Old 09-09-2003, 10:45 PM   #8
bird
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Original Poster
Rep: Reputation: 0
wow, you all are quite helpful! ill try all of these things. and yes, it is AC 97
 
Old 09-09-2003, 10:52 PM   #9
bird
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by nakkaya
did you try sndconfig ? go to terminal and type snd config it should find and configure it if you do not have it download it from rhn.redhat.com
It said my Sound card AC' 97 Audio (as stated above, that is the real name of my card) Audio Not Supported.
 
Old 09-09-2003, 10:54 PM   #10
bird
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by LordMorgul
Go to the main RedHat menu, to System Settings, to Soundcard Detection.

This utility should be able to initialize your soundcard if RedHat 9 supports it with what is already installed. If you cannot hear anything played out of the card by this utility, then you'll need to install and configure drivers yourself, but check this first.
"No Soundcard detected"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm doing exactly what the readme says newbsabott Linux - Newbie 6 06-23-2005 01:09 AM
qt compiling woes-Beware n00bish questions :) CelticWhisper Linux - Software 2 12-01-2004 05:36 PM
Software install readme says... Kaamp Linux - Newbie 3 09-01-2004 08:47 PM
I dont understand this Readme for Splashscreen fedivh Linux - Software 3 05-06-2004 09:05 PM
xmms not working like readme padlamoij Linux - Newbie 4 03-21-2003 04:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 10:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration