LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-02-2003, 07:42 AM   #1
caffeinelegacy
Newbie
 
Registered: Aug 2003
Posts: 10

Rep: Reputation: 0
Using my ADSL modem


Hey everyone.

I'm having trouble using my "Sagem FAST 800 ADSL usb modem"
I've installed the linux drivers that came with it, and it all seemed to go
smoothly. But how do I now get acsess to the modem.

When I try and setup a DSL connection it looks for a NIC card, which I
havent got, The modems directly plugged into the usb port. I've been attempting to use the modem for a few days now, and I'm convinced I'm
missing somthing really simple.

Please help, or I'll be stuck in 56k hell forever. =(

THanks

Last edited by caffeinelegacy; 09-02-2003 at 07:44 AM.
 
Old 09-05-2003, 09:31 AM   #2
NiallC
Member
 
Registered: Feb 2003
Distribution: Suse 8.1
Posts: 102

Rep: Reputation: 15
Have you looked at:

http://www.sagem.com/en/

There's support options for linux, which means you can contact them if you have some issues.

You might also look at the compusa USB-NIC adapter - $20. I don't know if it would/could work in reverse, as you require, but it's worth a shot.

You can always return these items if they don't work.

HTH
 
Old 09-10-2003, 04:29 PM   #3
claudiu_t
LQ Newbie
 
Registered: Sep 2003
Location: Paris, France
Distribution: SuSE 9
Posts: 10

Rep: Reputation: 0
hi,

I am trying to install myself drivers for Sagem Fast 800 USB modem, and that's what I've learned so far:
- the drivers you find on the sagem web site are bugged and won't function at all
- in order to install your modem correctly use the eagle-1.4.0_pre5 driver from http://sl33p3r.free.fr/eagle/; however this driver are configured for France ISP Free.fr so you might have to change some config files

HTH
 
Old 09-15-2003, 03:11 AM   #4
radhikan
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Rep: Reputation: 0
i tried to install & follow eagle 1.4.51 patch...no way

the answer to any adictrl comand is always:

"Unable to open any supported device!
Please check your modem is connected and (re)send it its firmware!"

wanna try adictrl -f (to send it it's firmware)?

"Unable to open any supported device!
Please check your modem is connected and (re)send it its firmware!"

can anybody help me?

don't tell me to read other guides...i've already tried 6!

it seems there's something wrong with this device

note that usbview detect it as "unknown device" SO IT IS CONNECTED
 
Old 09-15-2003, 03:35 PM   #5
claudiu_t
LQ Newbie
 
Registered: Sep 2003
Location: Paris, France
Distribution: SuSE 9
Posts: 10

Rep: Reputation: 0
Hi,

First of all check if your adiusbadsl module is loaded into memory

#lsmod

If your module is loaded check the state of the modem

#showstat

should read "Modem operational"

As for myself I obtain both leds of the modem green and Modem operational message but when I try startadsl script I get the "Can not determine local address" error message.
 
Old 09-15-2003, 03:46 PM   #6
jdtiede
Member
 
Registered: Apr 2003
Location: Baton Rouge, LA
Distribution: Kubuntu 12.04, 12.10, 13.04a
Posts: 244

Rep: Reputation: 30
I fooled around for two years with an Alcatel stingray ADSL modem and never could get it to work with Linux. I finally got a Speedstream 5360 (internet bridge) thru eBay and had it working in five minutes using RedHat Network Control. I'm on BellSouth FastAccess.
 
Old 09-15-2003, 04:07 PM   #7
claudiu_t
LQ Newbie
 
Registered: Sep 2003
Location: Paris, France
Distribution: SuSE 9
Posts: 10

Rep: Reputation: 0
I must confess that I didn't get work my Sagem F@ast 800 so I decided to buy a Netgear DG814 Ethernet modem, which is VERY simple to configure under Linux.
 
Old 09-16-2003, 04:20 AM   #8
radhikan
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Rep: Reputation: 0
ne comprerei un altro, il problema che Tiscali supporta solo il pppoa e che il modem in oggetto a noleggio
 
Old 09-16-2003, 04:42 AM   #9
radhikan
LQ Newbie
 
Registered: Sep 2003
Posts: 5

Rep: Reputation: 0
sorry for the answer in italian (i'm really tired...)

lsmod ---> adiusbadsl 47620 0 (unused)

showstat---> Pre-firmware device


any other suggestion?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SUSE 9.2 detect my [B]ADSL USB-Ethernet Modem-Router [/B] as a [B]Dial up modem[/B]. myprecius Linux - Hardware 0 06-27-2005 09:21 AM
What ADSL Modem? BongMong Linux - Newbie 5 07-27-2004 11:24 AM
ADSL Routers Setup- Microsom Deskporte router 100 and Planet ADSL modem router mabonline Linux - Hardware 1 02-27-2004 05:36 PM
ADSL eth modem and ISDN serial modem configuration zedrob Linux - Networking 6 01-19-2004 08:02 AM
ADSL modem - US -where crashmeister General 2 05-15-2003 04:23 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 05:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration