-   Linux - Hardware (
-   -   USBFS nor /proc/bus/usb exist... (

Gripp 03-25-2005 03:48 PM

USBFS nor /proc/bus/usb exist...
using gentoo with gnome and the 2.4 kernel i've ran into a bit of a problem

when i first installed gentoo onto this machine it was only intended to run as a firewall, but my good comp has recently gone to a better place (well the mobo atleast) so i never really expected to use this comp much...
this means i didn't include any support for USB from the start... just to eliminate one more potential problem

at any rate, this has turned into a bit of a nightmare...
upon trying to recompile my kernel to support USB and changing fstab to mount it to /proc/bus/usb i figured out that this directory doesn't exist, nor does it get created on boot...
i simply get the warning that it failed to mount becuase, well, it doesn't exist

i tried making the dir with mkdir, but this doesn't work, mkdir seems to take offense to the /proc structure
so, i decided to go ahead and mount it to /dev/usb

but now i get another error, that usbfs is not a valid file structure! (this is what it tells me on boot...)
also, i have tried the USB support as both modules and local


Half_Elf 03-25-2005 10:03 PM

you are most likely missing something in the kernel (but I can't tell you what extactly).
You shouldn't need to create anything to mount this into /proc, since /proc is a "special" directory into ram made by the kernel at boot. Adding usb later into kernel shouldn't be a problem usually.

All times are GMT -5. The time now is 08:09 PM.