LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   USB video grabber 1d19:6108 Dexatek Technology LTD (http://www.linuxquestions.org/questions/showthread.php?t=4175448254)

davetesc 02-01-2013 05:56 PM

USB video grabber 1d19:6108 Dexatek Technology LTD
 
just bought a video grabber usb device from Aldi, it returns the following from lsusb
lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E230/E270/E870 HSDPA/HSUPA Modem
Bus 001 Device 005: ID 1d19:6108 Dexatek Technology Ltd.

and dmesg gives
[ 2542.322447] usb 1-1: USB disconnect, device number 5
[ 2548.820255] usb 1-2: new high-speed USB device number 6 using ehci_hcd
[ 2548.955023] usb 1-2: New USB device found, idVendor=1d19, idProduct=6108
[ 2548.955033] usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2548.955041] usb 1-2: Product: Video Grabber
[ 2548.955046] usb 1-2: Manufacturer: DK
[ 2548.955051] usb 1-2: SerialNumber: 0000000000

I'm using Debian testing KDE 3.2.0-4-amd64 mainly.

Will this work under linux and if so how do I get it up and running for simple video / audio capture????

Thanks in advance for any help.

Davetesc.

H_TeXMeX_H 02-03-2013 04:06 AM

If you have mplayer installed try:

Code:

mplayer tv://

davetesc 02-16-2013 03:34 PM

TexMex
Tried your advice and got this......


dave@kpnqp:~$ mplayer tv://
MPlayer2 UNKNOWN (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv://.
Detected file format: TV
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
comment: first try, more to come ;-)
v4l2: unable to open '/dev/video0': No such file or directory
v4l2: ioctl set mute failed: Bad file descriptor
v4l2: 0 frames successfully processed, 0 frames dropped.
Opening as detected format "TV" failed.
Failed to recognize file format.


Exiting... (End of file)



I think this means that the hardware is not being recognised properly or the device needs a firmware file or setting up in some way but I'm lost as to what to try.
P.S. have checked it on vista and the hardware is working fine.

Thanks Davetesc.

H_TeXMeX_H 02-17-2013 03:30 AM

I don't see this video grabber supported on Linux using any drivers, sorry.

davetesc 02-19-2013 06:06 PM

Thanks for looking, it was cheap enough to take a punt, maybe it'll be supported at a later date, I've heard of a couple of sites where usb devices are listed as to compatibility in linux but haven't the addresses, if anybody knows where I can list this device to save anybody buying it needing it to work on linux please let me know so I can list it as not working.

Thanks

Davetesc

H_TeXMeX_H 02-20-2013 02:49 AM

You can list it here:
http://www.linuxtv.org/wiki/index.ph...ce_Information
But usually they list devices that work.

hughberto newbie 03-01-2013 04:56 PM

Same thing so I'll try hardware hacking..
 
Hello there I have exactly the same problem with my HD DVD Maker yoke. But I'm itching for a project to get this thing on the road. I have the box so I'll give it a go on windows first and then the .inf and maybe .elf and try to parse the data stream the yoke will surely (hopefully) spit out at me. Heres my output of lsusb:

Code:

Bus 002 Device 003: ID 1d19:6108 Dexatek Technology Ltd.
I'm planning on getting the USB Video capture device working with video4linux or else usb dvr/pvr or something.
First I need it to talk to alsa nicely. I'll try PCM encoding or I2C at the very least.
Anybody have any other ideas info please please post the stuff out. Thanks!!

davetesc 03-06-2013 06:23 PM

usb vid grabber
 
Thanks, good to know I'm not the only one trying to get one of these working.
So far I've tried it using win Vista and it works so I know I've got working hardware.
I've also tried it on a Win XP virtual machine running under lubuntu, the s/ware installs fine but although it tried to communicate with the usb dongle it gets nowhere.
I'm hopeful that either there is a piece of firmware out there for this or soon someone will create one.
Can add more detail if needed, but only have occasional inet access so may not be online.

Thanks again. Davetesc

SaintDanBert 05-19-2013 02:50 PM

Quote:

Originally Posted by H_TeXMeX_H (Post 4883477)
The fewer dependencies, the better.
~ Occam's razor, my interpretation

While I appreciate the sentiment that you imply, avoiding "dependencies" as a generic bad thing, limits one's ability to build on the success of others.
Occam's or Ockham's Razor argues that it might be better to choose the theory with the fewest assumptions. Building an application with a collection of proven to work components offers more success than creating all of those same features from scratch such that they must be proven again.

~~~ 0;-Dan


All times are GMT -5. The time now is 02:18 AM.