LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-17-2002, 11:27 PM   #1
Mikest
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Rep: Reputation: 0
Unhappy USB USB-CDRW Drive


I am unable to mount my Sony Supressa USB CDRW. It shows up in the Partitions in the Control Center as /dev/cdrom1 with a Mount Point of /mnt/cdrom1. FS Type = iso9660. Mount Option noauto, owner, kudzu.ro.

When I try to mount it I get the following error:
mount: wrong FS type, bad option, bad superblock on /dev/cdrom1, or too many mounted file system.


 
Old 10-18-2002, 02:06 AM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu ; CentOS ; Raspbian
Posts: 12,613

Rep: Reputation: 69
How are you trying to mount it?
 
Old 10-18-2002, 11:16 AM   #3
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
Are you mounting blank/audio CD?

To my best knowledge, only RH8 can recognize USB 1.1 and 2.0 CD burners with default install.
 
Old 10-18-2002, 08:11 PM   #4
Mikest
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Original Poster
Rep: Reputation: 0
RH 8.0 using KDiskFee, right click on device and selecting mount. This method works just fine on my IDE Zip and my other IDE CDR drive mounts automatically when a disk is inserted

The drive is a Sony Spressa CRX100E/X, USB 1 device
 
Old 10-18-2002, 09:16 PM   #5
jetblackz
Member
 
Registered: Mar 2002
Location: Debian Galaxy
Distribution: Debian
Posts: 711

Rep: Reputation: 30
ls -l /dev/cdrom1
su
cdrecord -scanbus
Post results here
 
Old 10-19-2002, 02:38 PM   #6
Mikest
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Original Poster
Rep: Reputation: 0
You have to remember you are talking to a newbie "ls" is a command for a directory on a mounted drive from my understanding but since I know very little I tried typing:

# ls -l /dev/cdrom1 su cdrecord -scanbus

I got the following error:

ls: su: No such file or directory
ls: cdrecord: No such file or directory
0 lrwxrwxrwx 1 0 0 9 Oct 19 12:30 /dev/cdrom1 -> /dev/scd1
 
Old 10-19-2002, 02:49 PM   #7
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Mostly Debian based systems
Posts: 4,368

Rep: Reputation: 64
The commands should be entered as discreet commands:
ls -l /dev/cdrom1 (press enter)
su (press enter)
(should ask you for root's password)
cdrecord -scanbus (press enter)
exit (press enter)
(returns you to normal user mode instead of root mode)

Now, the fact that your last line shows the device /dev/cdrom1 to be linked to the scsi-cdrom scd1 shows that it has recognised your USB CDRW and has loaded the appropriate module(s). You should now only need to give the output of cdrecord -scanbus (done as root).
 
Old 10-19-2002, 04:07 PM   #8
Mikest
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks! Duh I feel like such a computer newbie (am actually not I've been working in the non-linux computer field for 15 years)

Okay that apparently worked (see below). I am still unable to mount or at least browse the contents of cdrom1 (/mnt/cdrom1). I tried using KdiskFree, right click and mount as in the original thread message. I get the same error message. Thinking that the contents of the /etc/fstab file were incorrect I tried manually mounting:

# mount -t iso9660 /dev/cdrom1 /mnt/cdrom1
mount: block device /dev/cdrom1 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/cdrom1,
or too many mounted file systems

I eventually want to to auto-mount...there is obviously a way. I got my IDE-RAID drives working which was major success (at least for me). TMI I know...anyway your assistance to this point is appreciated.

Cdrecord 1.10 (i686-pc-linux-gnu) Copyright (C) 1995-2001 J?rg Schilling
Linux sg driver version: 3.1.24
Using libscg version 'schily-0.5'
scsibus0:
0,0,0 0) 'SAMSUNG ' 'CDRW/DVD SM-332B' 'T402' Removable CD-ROM
0,1,0 1) *
0,2,0 2) *
0,3,0 3) *
0,4,0 4) *
0,5,0 5) *
0,6,0 6) *
0,7,0 7) *
scsibus1:
1,0,0 100) 'SONY ' 'CD-RW CRX100E ' '1.0j' Removable CD-ROM
1,1,0 101) *
1,2,0 102) *
1,3,0 103) *
1,4,0 104) *
1,5,0 105) *
1,6,0 106) *
1,7,0 107) *

******************************
Contents of fstab:
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,kudzu,ro 0 0

Last edited by Mikest; 10-19-2002 at 04:08 PM.
 
Old 10-19-2002, 04:10 PM   #9
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Mostly Debian based systems
Posts: 4,368

Rep: Reputation: 64
OK, well try the following:
mount /dev/scd0 /mnt/cdrom1
Or:
mount -t iso9660 /dev/scd1 /mnt/cdrom1
 
Old 10-19-2002, 04:30 PM   #10
Mikest
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Original Poster
Rep: Reputation: 0
No luck?

# mount -t iso9660 /dev/scd1 /mnt/cdrom1

mount: block device /dev/scd1 is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/scd1,
or too many mounted file systems


# mount /dev/scd1 /mnt/cdrom1

/dev/scd1: Input/output error
mount: block device /dev/scd1 is write-protected, mounting read-only
/dev/scd1: Input/output error
mount: you must specify the filesystem type
 
Old 10-19-2002, 05:12 PM   #11
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu ; CentOS ; Raspbian
Posts: 12,613

Rep: Reputation: 69
Ok, give this one a try, as a shot in the dark effort:

mount -t iso9660 /dev/sda1 /mnt/cdrom1

Cool
 
Old 10-19-2002, 05:42 PM   #12
Mikest
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Original Poster
Rep: Reputation: 0
This is message I got

mount: /dev/sda1 is not a valid block device
 
Old 10-19-2002, 05:46 PM   #13
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu ; CentOS ; Raspbian
Posts: 12,613

Rep: Reputation: 69
Can you post the output of mount? (open up a console and type 'mount' without the ' )

And also the output of 'ls -l /dev/scd1' (LS -L /dev/scd1 lowercase)

Cool

Last edited by MasterC; 10-19-2002 at 05:48 PM.
 
Old 10-19-2002, 06:07 PM   #14
Mikest
LQ Newbie
 
Registered: Oct 2002
Posts: 15

Original Poster
Rep: Reputation: 0
Mount =

/dev/hda3 on / type ext3 (rw)
none on /proc type proc (rw)
usbdevfs on /proc/bus/usb type usbdevfs (rw)
none on /dev/pts type devpts (rw,gid=5,mode=620)
none on /dev/shm type tmpfs (rw)
/dev/hde1 on /mnt/vfat_e type vfat (rw)
/dev/hdf1 on /mnt/vfat_f type vfat (rw)
/dev/cdrom on /mnt/cdrom type iso9660 (ro,nosuid,nodev)

ls -l /dev/scd1=

brw-rw---- 1 root disk 11, 1 Aug 30 16:31 /dev/scd1
 
Old 10-19-2002, 06:12 PM   #15
Thymox
Senior Member
 
Registered: Apr 2001
Location: Plymouth, England.
Distribution: Mostly Debian based systems
Posts: 4,368

Rep: Reputation: 64
What does running usbview show?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to mount usb cdrw drive sbhaid Linux - Newbie 2 11-12-2005 09:03 AM
Linux on a USB hard drive without USB-FDD BIOS option jaro Linux - Hardware 1 07-15-2005 02:12 AM
USB drive using different partitions (usb key thumb drive) Arodef Linux - Hardware 0 08-04-2004 06:36 PM
Linux on a USB hard drive without USB-FDD BIOS option jaro Linux - Hardware 6 05-27-2004 11:49 AM
Cannot mount usb Hd or usb CDRW Pollux Linux - General 8 11-23-2002 01:08 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:09 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration