LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   usb stick - no write permissions (http://www.linuxquestions.org/questions/showthread.php?t=4175441544)

kox444 12-15-2012 06:05 AM

usb stick - no write permissions
 
I have had a usb stick. Back in the day it worked completely fine, but one day it started mounting only as read only filesystem. I tried to format it but I wasn't able. Now I dig it out because I need it. Again I tried to format it on linux, windows xp, gparted live cd. Nothing worked. Filesystem is read only. I wonder can I do something about it or is it just broken?

amani 12-15-2012 11:32 AM

clean it with iso-propanol and use a hair dryer on it.... try

Shadow_7 12-15-2012 11:55 AM

Some of them have a little lever to write protect them. If yours has such a thing try moving it to the other position. Or there and back as it may have shifted to a mid-position over time. Otherwise if you don't care about the current contents of the device you can try to dd over it in linux and see if that helps.

# dd if=/dev/zero of=/dev/(usb_location) bs=8M

If that works then I don't see why you wouldn't be able to partition and format it like any old storage device.

DeadlyWolf 01-07-2013 01:17 AM

Try to delete the partition then create a new one and format it as you require.


All times are GMT -5. The time now is 10:14 AM.