LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   USB Printers Within on Mandrake Linux Community 10.1 (https://www.linuxquestions.org/questions/linux-hardware-18/usb-printers-within-on-mandrake-linux-community-10-1-a-616170/)

des_a 01-24-2008 11:08 PM

USB Printers Within on Mandrake Linux Community 10.1
 
I previously ended up solving a DNS issue by finding a simple patch I could create because I was able to finally see within how DNS worked. So, I'm also having a small issue with my printer that should be able to be solved with a patch if I could see how it worked within.

I used to once upon a time, leave my HP PSC 1300 Series on all the time. This was back when it worked easily with a simple local setup by installing the Windows driver for it on Windows. I know now, I'll have issues if I did the same thing now, because I use my laptop mostly, which can be wired or wireless. So a simple local setup would create a "disappearing printer".

This simple fact, meant that when my origional network ideas weren't perfect, I still could not go back to a simple local printer setup. Note that this printer includes a scanner, as it is a PSC (Printer, Scanner, Copier). This is USB.

It's successfully hooked up to a machine running Mandrake Linux Community 10.1. So first of all, to get past my initial assumption from what people told me, will or will the ink not dry up, if I left the printer on all the time, and still didn't use it "every day"? This is my first ever printer that I actually own and attempt to maintain, so I don't know much about what dries ink up or the differences/advantages between different types of printers.

Next, I'm noticing a simple problem. I'd configure it, using the GUI tool (I believe I initially configured it with the installation program). Hardware Autodetection is on, to my memory also, if that makes a difference. This would've been via the installation program, and I've got no idea how to do it manually.

I know I added some configuration using the printer drake wizard GUI tool. Right after configuring it, and closing the program, I turned the printer off, both to save power, and according to other people, to save ink from drying up too fast. I'd turn it on, when I needed to print to it, or scan from it, etc.

There were no obvious problems with this initially. At one point I even remember turning it back on, and there were no issues yet. It knew the printer was being turned on, and it knew when it was off. (I'm testing an installation, so this may not be the time I did that)

When I rebooted for the first time after finishing printer configuration via the wizard, that's when I pinpointed that I've got the problem. Say, the printer was in an off state when I rebooted (which it was by then). Now when I reboot, it detects it's in an off state. I belive it says that the printer is disabled. That's true. But when I turn it on, the printer should be recognized that it's in an on state while the system is still running, and then it should enable the printer, but it doesn't.

This may very well be due to a bug. Even if it is, however, the current best thing to do, would be to figure out where the bug is, and manually patch it. Now I'm not talking about C++/C bugs, or recompiling the kernel. If this is the only thing that would fix it (or upgrading), then in interest of time, I guess I'll try a different way to do this, by running Windows underneath and then Linux on top, but prefferebly, I'd rather not do this, because the machine will perform loads better using Linux.

So, I'm looking for an explanation of how Linux printers work, and how I can use scripts to catch events and stuff like that. Perhaps it's not running the right program when hotplug runs? Where do I find the script files to manipulate printer type events?

aus9 01-25-2008 04:36 AM

that distro version is old...can I suggest you move to Mdv 2008.0 free of course...the GPL edition.

2) as a rule....usb printers should be turned on...if they have a separate power switch and then the usb jack plugged into your usb port.

3) to install any usb printer....open a web browser with root powers

eg if you use firefox...open a shell and type
su (and passwd)
firefox

----
after it loads type the following in the url address bar

localhost:631 (and press enter)

if Common Unix printer page is displayed you have reached CUPS and can click on add printer button and follow the steps to add any printer.

----
if you get unavailable error message of some sort...check that cups (the service) is running....go into Mdv control centre.../system/manage services....if you are not short of memory...allow cups to start at boot...if infrequent printer...leave it off and turn on or off from here

then retry localhost in web browser

aus9 01-25-2008 04:48 AM

the above is the easiest gui way.

now if you like to torture yourself? read /usr/share/doc/cups/readme which will give you commands you can use to print a file.

2) http://www.cups.org/index.php has links to docs and user mailing list


All times are GMT -5. The time now is 11:50 PM.