-   Linux - Hardware (
-   -   USB ports work with flash drive but not camera (

M$ISBS 04-06-2007 06:54 PM

USB ports work with flash drive but not camera
Hello Friends. I have got the USB port to work and I can use a flash drive but when I try my digital camera it does not do anything when I try to mount it. I thought it was the same as using a flash drive, is it not?

Thank you for any insight for steps that I can take to get my digital camera working.

I am using slackware 11 and KDE 3.5

thecarpy 04-06-2007 07:25 PM

dmesg is your friend!

It should indicate the if the camera can act as a mass storage device. You get a /dev/sd?1 ... just mount that filesystem ... it's usually fat.

If this is not the case, please report camera model and distro.

M$ISBS 04-06-2007 08:12 PM

When I plug in the camera and turn it on, this is what dmesg shows.

hub.c: new USB device 00:1d.7-3.1, assigned address 3
usb.c: USB device 3 (vend/prod 0x40a/0x57b) is not claimed by any active driver.

when I try to mount it in console I get the message /dev/sda1 is not a valid block device and I also tried to mount /mnt/flash.
I just downloaded gphoto and the library, when I do gphoto2 --auto-detect it sees the camera name/model but I dont know what else to do.

The camera is a kodak easyshare CX7430

M$ISBS 04-06-2007 09:14 PM

I got it.

I Downloaded gphoto2 and the library (for slackware, tgz file)from here....

installed them

turned on the camera

typed gphoto --auto-detect

then typed gphoto2 -P

and it copied all the pics to my downloads folder.

Dont know why it chose there but at least it worked.


All times are GMT -5. The time now is 12:53 AM.