LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   USB not recognized and two other problems (https://www.linuxquestions.org/questions/linux-hardware-18/usb-not-recognized-and-two-other-problems-234882/)

linuxnewbie24 09-24-2004 05:10 PM

USB not recognized and two other problems
 
I am a Linux Newbie and not a programmer. I'm trying to set up a server for the various computers in my house to share storage and a printer. I have been running RH9 for a while on an old laptop and had a measure of success with it. Now I am trying to convert an old (P3-500) Win98 system to an FC2 server. The basic installation works pretty well, and I have the desktop running so I can do things on it.

Problem #1: It doesn't recognize my USB printer at all. I have an HP OfficeJet G55 which is on the supported list for both CUPS and SANE. But the system doesn't even know it is there. Is there something special I have to do to make the USB ports live again? They work fine on the Win98 system. Am I missing something in the installation I chose? (In looking through the various fora and some books I have seen some suggested commands, like MODPROBE, LSUSB, and HWBROWSER. This brings me to my second problem)

Problem #2: When I try to execute some of these commands I get a message that says
"bash: modprobe: command not found". What am I missing here. These are supposed to be real commands that I can execute either as a user or as root, but they don't work. This kind of thing used to work for me on RH9 (if I remember correctly.) Where do I go or what do I have to do to be able to execute them?

Problem #3: Where can I find an explanation of the colors in the output from the "ls" command? I know the blue ones are directories, but there are also aqua ones. A link to something would be very helpful.

Thanks for your help,

kersten78 09-24-2004 06:34 PM

You can enable usb support by editing your /etc/rc.d/modules.conf file.
It's commented very well, so just scroll through it until you hit the usb section. I think the first one to uncomment is the usb-uhci module. That should get the usb hub going. Then there's a bunch of different modules for mice, keyboard, etc, etc. Just uncomment the ones that you need.
The modprobe problem could be a problem with your $PATH. I can't remember how to edit the $PATH variable... But modprobe is in /usr/sbin/ and that should be in your path by default. You could try running it with the full path "/usr/sbin/modprobe [module]"
Hope this helps.

linuxnewbie24 09-24-2004 07:29 PM

Thanks for your response.

Quote:

Originally posted by kersten78
You can enable usb support by editing your /etc/rc.d/modules.conf file.
It's commented very well, so just scroll through it until you hit the usb section. I think the first one to uncomment is the usb-uhci module. That should get the usb hub going. Then there's a bunch of different modules for mice, keyboard, etc, etc. Just uncomment the ones that you need.

First of all, I found modules.conf and modules.conf~ directly in /etc/, not in any of the subdirectories. When I did go into the file there was an entry that reads "alias USB Controller usb-uhci" and it was a very short file. Is that what you were talking about?

Quote:

Originally posted by kersten78
The modprobe problem could be a problem with your $PATH. I can't remember how to edit the $PATH variable... But modprobe is in /usr/sbin/ and that should be in your path by default. You could try running it with the full path "/usr/sbin/modprobe [module]"
Hope this helps.

I got some advice from another list that if I did an "su -" instead of "su" it would work because the $PATH would be set up properly for root. It worked!

Thanks for your help. Any ideas you have about modules.conf would be appreciated.

kersten78 09-25-2004 02:12 AM

Sorry. The file is /etc/rc.d/rc.modules

Also, that's great about the "su -" thing. I never knew what it did--I always just did a plain ol "su". It must give you the root $PATH.
Anyway, check out rc.modules--it should have the usb mods.


All times are GMT -5. The time now is 02:58 AM.