-   Linux - Hardware (
-   -   USB MP3 Player Won't Mount (Philips PSA232) (

redrun 11-05-2005 02:56 AM

USB MP3 Player Won't Mount (Philips PSA232)
I have a Philips PSA232 flash MP3 player. When I plug it in, all I get from dmesg is this:

usb 1-2: new high speed USB device using ehci_hcd and address 9

The system then seems to think I've plugged in a camera because it runs the camera import tool, which I cancel out of. No new devices are created in /dev. usb-storage and sd_mod are loaded. The entry in /proc/bus/usb/devices looks like this:

T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#= 2 Spd=480 MxCh= 0
D: Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs= 1
P: Vendor=0471 ProdID=7e01 Rev= 0.01
S: Manufacturer=Philips Semiconductors
S: Product=Philips
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=06(still) Sub=01 Prot=01 Driver=(none)
E: Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E: Ad=82(I) Atr=03(Int.) MxPS= 64 Ivl=1ms

I read up on hotplug, but haven't found any docs that say how to add actions for an unknown device. I hacked usb.agent to write the device data to a file and then tried to add a line to usb.distmap with those values, but I had to guess on some of the fields and it didn't work.
This is on a Fedora Core 4 system with Kernel 2.6.13-1.1532_FC4.

Any ideas?

Simon Bridge 11-05-2005 03:05 AM

Have you tried the mount tool?

I have this with a supermarket brand player, it loads the camera dialog which I cancel out of. Then I open the user mount tool, unmount the new entry there, the mount it again. An icon appears on the desktop.

Basically, if the camera tool sees it, then it is mountable.

redrun 11-05-2005 03:16 AM

Even though the camera tool runs, nothing new is created in /dev to mount. The mount tool doesn't show anything, either :(

Simon Bridge 11-20-2005 12:18 AM


unplug the device then do dmesg | grep usb
Take a look at the last few entries so you know what they are. (Probably something about the usb device being disconnected...)

plug the device back in again, then repeat

dmesg | grep usb

and post the differences.

(you can also pipe the output to text files and run the diff command on them.)


[4314341.650000] usb 2-3: new full speed USB device using ohci_hcd and address 2[4314343.415000] usb-storage: device found at 2
[4314343.415000] usb-storage: waiting for device to settle before scanning
[4314343.415000] usbcore: registered new driver usb-storage
[4314348.431000] usb-storage: device scan complete

... this is the sort of thing that corresponds to my device.

An intreguing idea would be to put some photos on it and see if the camera tool can import them... basically, if it is seen in the camera tool, then it has been mounted.

In my FC4 system, a device is created at /dev/sde (if I use the front panel socket) and it is automounted to /media/usbstick. I note that /dev has sda,b,c and d already, creating sde when I plug in.

/proc/bus/usb/devices shows 5 when plugged in and 4 when not - as expected.

[~]$ cat /proc/bus/usb/devices > unplugged
[~]$ cat /proc/bus/usb/devices > plugged
[~]$ diff plugged unplugged
> T:  Bus=02 Lev=01 Prnt=01 Port=02 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
> D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS= 8 #Cfgs=  1
> P:  Vendor=10d6 ProdID=1100 Rev= 1.00
> S:  Product=USB 2.0(FS) FLASH DISK
> S:  SerialNumber=USB 2.0(FS) FLASH DISK
> C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=100mA
> I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=05 Prot=50 Driver=usb-storage
> E:  Ad=01(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
> E:  Ad=82(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms

... as you can see, my disk is identified. The "unknown" you are getting suggests that your device simple is not telling your computer what it is.

You may need to check with your dosumentation for your mp3 player. It is possible that it dosn't use a standard storage type. Or there may be some setting on the HW so it can be used as a storage device.

However - connection protocol matters. If it is regestering as a camera, then perhaps it is using PTP ... the documentation will tell you about connection types supported.

A puzzle, because all these players I've tried just look like a usb drive.

You could try the mount command on /dev/sda sdb etc until you get a hit. This is the traditional method.

mount -t vfat /dev/sda /media/usbstick

All times are GMT -5. The time now is 06:07 AM.