-   Linux - Hardware (
-   -   USB mouse support thru usb "hub" of MS keyboard.. (

zeppelin 07-28-2003 12:40 PM

USB mouse support thru usb "hub" of MS keyboard..
hello. I recently bought a new mouse (USB wheel mouse). The last mouse was on PS/2 port. I now want to be able to plug the USB mouse in the USB 'hub' of the Microsoft's Natural Keyboard pro (is it really a hub?). Yet in Windows works.. I even plugged it in USB port on my motherboard yet I had some problems to say to linux where to look and what to do.. I use SlackWare. Any help would be appreciated.. (I know you got tired of USB mouses and all that stuff, yet I searched for USB keyboard's hub, and found nothing..)

faheyd 07-28-2003 11:05 PM

Please see as you have two things going on. One, you have to check that your USB hardware is being discovered, and second, you have to configure your "X" windows to know how to treat the USB device.
I'm not using any USB KB or Mouse, but the above document looked pretty straight forward, but be prepared for lockups while configuring X-windows on the new mouse/keyboard combination.
You might look into using single user mode on your system as you mess with it, see your /etc/inittab file, specifically,

# Default runlevel. The runlevels used by Mandrake Linux are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)

so changing to


will allow you to manually start X-windows while you mess with it, then you can change it back to init 5, when things are running ok.
(see startx to manually start X-windows).

zeppelin 07-29-2003 03:40 PM

thank you. I must say I came into that html file earlier.. I was going to do all that stuff. Suddenly the kernel did some MAGIC!
a) in one boot, kernel saw the mouse as INTELLI MOUSE 3BUTTON

b) afterwards I got disappointed..
BUT, I disabled automatic gpm launch while booting.. (this was needed once)
The settings in GPM and XF86CONFIG file were the SAME (and are the same, that is working flawlessly)
After DISABLING the GPM, I had my pc working..
I then tried to enable GPM (automatically, rather than typing manually the stuff- when I did that manually worked fine [the same settings!] and guess what, now it works AUTOMATICALLY and all go well)

I didn't change anything, and all works as I had changed sth.. :|
don't know if anyone believes me, yet I now have other MOUSEDEV, KEYBDEV, INPUT (important!) and HID (or the heck is that!)

Don't know if the problem was that SLACKWARE wanted once to boot without gpm (but that fixed my problem) Go figure..

[the whole thing reminded me a bit of WINDOWS.. hehe]
Now I am happy and working (hope the USB-magic keeps working!)

if anyone has a explaination about the GPM making problem to the kernel I can listen to him.. (you see I don't believe in MAGIC)

faheyd 07-29-2003 11:25 PM

Slackware obviously loaded the Magic.RPM upon reboot. It happens only once in every million computing hours to a few special people. You are one of the lucky ones!!!

All times are GMT -5. The time now is 01:09 AM.