-   Linux - Hardware (
-   -   usb mounting problem with hal and friends (

mister.teapots 11-16-2007 06:54 AM

usb mounting problem with hal and friends
I have a laptop that loves Linux - every distribution works - Ubuntu 6.06 LTS, 7.04, 7.10, Suse 10.1, 10.2, 10.3, Debian, Fedora...suspend, resume, wireless, everything works. So you can imagine how annoying it is when my 'generic' mass storage device won't mount - it worked in Ubuntu 6.06 LTS, because there was an older HAL then, but then HAL got updated and "sorry, Dave, sorry" now I can't use Linux at all because I really need this device. It isn't anything special - it only uses vfat for its partition type, and it has a cable because it doubles as a music player (a Sony HI-MD Mini Disc to be precise).

...However, recently I find that Debian Etch actually CAN mount my device - hurray! The problem is I'm forever having to do this through the terminal window by implementing mount /dev/sdb /media/usbdisk which works perfectly. Thing is, Gnome already makes icons for the device in My Computer, however if you double-click the icon you get a long error message about the time libhal lived on a mountain with three goats and a little girl called wait, wrong story...but it is a long explanation - and it makes no sense, rest assured. The main message I can understand is UNABLE TO MOUNT VOLUME. On Ubuntu, Suse and Fedora the message is slightly different - UNABLE TO MOUNT VOLUME: THERE IS NO MEDIA IN THE DRIVE.

Interestingly, if I do a dual-boot setup with Windows XP and Debian together, Debian will give me the same UNABLE TO MOUNT message if I try to mount the Windows partition from inside the same Gnome window. Given that the error message does involve libhal, I would say its some problem with HAL or one of HAL's stupid friends (Dave maybe?) - just surprising that the error repeated itself when I tried to access my windows partition.

By the way, if you want a good Linux laptop, the Dell Inspiron 6400/1505E works a charm - as long as you have the Intel 945gm videocard instead of the ATI or nVideo one, as they break suspend in a lot of cases.

Thanks for the assistance! I think that heaps of people have this same problem.

onebuck 11-16-2007 07:28 AM


Do you have the user in the 'plugdev' group? If not you can add the user to that group to allow access to the device(s). Look at the '/etc/group' file to see if the user is in that group.

mister.teapots 11-18-2007 02:31 AM

Wow I haven't tried that - thanks! I've tried nearly everything else, so I'll give it a go. Sadly I don't have Debian installed at present, so I'll have to see if this corresponds to Ubuntu Gutsy. I'd say it would - they are similar in ways. Thanks for your help - I'll tell you how it goes.

Could also be something to do with this:

However your suggestion about the users and privileges reminds me of this:

mister.teapots 11-19-2007 01:02 AM

Tried it, but it didn't work. Thanks a lot anyway. I also looked into this problem by following the beforementioned links, to no avail. It seems that this is a problem that has wide ranging implications. Not sure if there will be a fix this century either.

All times are GMT -5. The time now is 02:28 PM.