-   Linux - Hardware (
-   -   USB memory key hangs boot (

enryfox 07-17-2004 07:51 AM

USB memory key hangs boot
Suse 9.1 installed on a IBM thinkpad T40. I have a problem with my 256 memory key. If plugged at startup then boot hangs after Domain name caching and resume only if memory key is removed. If i plug the card after boot and try to mount it with "mount /dev/sda /windows/usbkey" the shell hangs and only when i remove the key i get "/dev/sda is not a valid block".
I tried disbling hotplug and acpi but no success...
Added to some other minor problem i very near to format and install mdk10 ...


shedir 07-17-2004 11:57 AM

Maybe it's just typed wrong, but

"mount /dev/sda /windows/usbkey"
should be /dev/sda(123....).

enryfox 07-17-2004 01:25 PM

hi thanks for your reply.

the command it's typed correctly: i've read somewhere that a usbkey has just one partition therefore there is no need of sda1.
Anyway i also tried sda1 and the results is absolutely the same.

shedir 07-17-2004 07:04 PM


it's right, the usbkey has only 1 partition (normaly) but /dev/sda refers to the entire disk (key). So you have to specify the number of the (unique) partition.
It's odd that the mount command hangs the shell without any output.
Are you sure that the right type of usb-module is loaded (ohci/uhci) in other words do other usb devices work?
Is usb-storage and sd_mod loaded?
And what says dmesg after plugging the usbkey?

The output should look like:
usb 2-1: new full speed USB device using address 3
scsi1 : SCSI emulation for USB Mass Storage devices
Vendor: YAKUMO Model: Quicksave 2.0 Rev: 2.00
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sda: 256000 512-byte hdwr sectors (131 MB)
sda: assuming Write Enabled
sda: assuming drive cache: write through
sda: sda1 sda2
Attached scsi removable disk sda at scsi1, channel 0, id 0, lun 0
USB Mass Storage device found at 3

enryfox 07-18-2004 03:04 AM

Hi, thanks again.

Yes, all modules are loaded correctly, other usb devices work perfectly (a logitech otical mouse) and the messages i get in /var/log/messages are exactly the same as yours (except of course for size and vendor of the key). Anyway im going to solve the problem from tha base: this afternoon i'm going to install mdk10 and i think it will work correctly (on another pc with mdk10 works correctly and with mandrake-move also works correctly)...

thanks for your help

All times are GMT -5. The time now is 03:22 AM.