-   Linux - Hardware (
-   -   USB memory, Compact Flash, Memory Stick (

energiza 08-22-2006 08:29 PM

USB memory, Compact Flash, Memory Stick
I was working with these 3 types of memories until last week. About 2 days ago I was seeing that the services were starting or not starting at boot time (some times apache was on, sometimes off, and likewise for mysql and samba), so I went to the runlevel editor and noticed many services with Yes* or No* (enabled but not running or not enabled and running). So I went over all the services and kept apache, samba, firewall, cron, netbios, etc., as Enabled and "other" (?) as disabled. After that now my services start ok at boot time.

When I insert the USB memory, the kernel reports to the "messages" log that such memory is connected, but is not shown in the /media folder (as before). With CF and MS, the Kernel is not even aware of those cards, and there are no reports to the log.

I have enabled the Smart Card reader, but it was not enabled before I went to the runlevel editor. I tried disabling it again, but no change. If I ask for a report of Hardware Information (in YaST), only the USB memory is shown listed (Kingston Data Traveler), but still it is not shown in the /media folder.

The Suse Plugger is configured to Inform of New hardware, but nothing happens when I insert my memory cards. By the way,(I don't know if this is useful) this suse plugger, shows under "unknown" device to the CPU P-IV 3.0 GHz,the PnP, the Linux Host Controller, Main Memory and 3 partitions, etc.

Any idea of what I "moved" to the wrong side?

My OS is shown on my profile.

Thanks for the help.

kilgoretrout 08-22-2006 08:48 PM

See if you have a sevice named "hal" or "HAL". It should be enabled in most distros for autodetection of usb storage devices.

energiza 08-22-2006 09:29 PM

Like Magic!, thanks!!!

When trying to enable this HAL service, I got a notice from YaST, that boot.clock needed to be started as well. Both services started but the boot.clock is not shown in the services list. It did show a message box reporting success on both boot.clock start and hal start. Though there is a /etc/rc.d/boot.clock and chkconfig -l reflects proper start of boot.clock in runlevels 2,3 and 5, so I think it will be restarting ok on boot.

About the suseplugger. I like the message box saying "A new hardware was found". The suseplugger has the checkbox for "inform me about new hardware" and I tried all combinations of checkboxes: without it, without the kfmclient, without the "directly start application", etc, and the only 2 results I get are: konqueror does not pop up but /media shows the usb drive connected, OR, konqueror pops up AND /media shows the drive connected, but I don't see that box saying "new hardware found", that is the default in a newly installed version of SuSE 9.3.

Thanks for the help again.

All times are GMT -5. The time now is 02:12 PM.