-   Linux - Hardware (
-   -   USB keyboard function keys/numeric keys on boot (

raypen 04-15-2008 09:59 AM

USB keyboard function keys/numeric keys on boot
I have spent an inordinate amount of time on this issue and am
left with asking the question here in the hope someone will have a clue.

I have just purchased an integrated USB keyboard/mouse (Scorpius p20)
and have connected it to one of the two 1.1 USB ports on my FIC AD-11
motherboard. I have USB keyboard/mouse support turned on in the BIOS.

The keyboard/mouse combination works just fine in Windows 2000 and
Slackware Linux 10.2. The problem is boot. The function keys are
non-operational in ntloader although I can use the cursor keys to make
a boot selection. If I press F8 nothing happens. If I boot a
SystemRescueCD (based on Gentoo Linux), none of the function keys work
to display the help menus and I cannot enter numeric data at the prompt.
(i.e. typing 123 results in !@#). Hitting CAPS lock does nothing and,
because there is no keypad, pressing Fn to turn on the embedded keypad
produces alpha data only.

I first suspected that USB BIOS support was somehow limited, but that
seems unlikely given the simple nature of keyboard operations. I can only
surmise that something else is interfering with proper operation.

I seem to recall reading something about USB scan codes having to be
converted to PS/2 codes or at least some sort of translation in order
for the keyboard controller to properly interpret key presses. I can't
tell if this is a hardware or a software problem, or one of just limited
USB support.

Can anyone help here?

ronlau9 04-15-2008 10:54 AM

First I Use USB keyboard and mouse both USB wireless
Typing 123 giving !@# means that shift key is on
If I startup and press the del key and get BIOS message than BIOS is already recognize correctly my keyboard and mouse
In my BIOS setup PS2 support I disabled it I disabled because anyhow in the past PS2 stands for Personal computer system 2
In my opinion for some reason in the beginning the shift key is on and if it is on pressing an other function will not work

all the best

raypen 04-15-2008 10:52 PM

I must apologize. It turns out that I can use the embedded keypad
(pressing Fn) to input numeric data. I could have sworn I tested that
before, but I am apparently somewhat addled.

You are right, the "Shift" key or "Caps Lock" is on when the computer
first boots, before the OS is loaded. If I press "Caps Lock", the
shift is turned off and I get lower case letters instead of "Caps".
However, it does nothing for the numeric keys which remain upshifted
to produce !@# when 123 is pressed. Small inconvenience here and not
life threatening.

Function keys are another matter; they still don't work at all. I have
no way to disable PS/2 in my BIOS, in fact I don't think I would want
to since I may need a PS/2 keyboard and mouse if certain situations
arise. However, you did give me an idea. I thought that if PS/2 might
be interfering, maybe the USB mouse is also. I turned off BIOS USB
mouse support only to test this theory. Same result.

I tried turning "Caps Lock" on again to see if that effected the
function keys. It did not. I tried other combinations including turning
on Fn, none of which would make the function keys work. It would
appear that somehow, function key programming is somehow absent or, as
I mentioned before, is being improperly translated to PS/2 equivalents.

Any more input, suggestions?

ronlau9 04-16-2008 02:05 AM

If I am right that the shift key is on before the OS is loaded , it only can means that let say the way the BIOS treated
the keyboard is not correct. IS it possible for you to try an other keyboard
AS a example a use Asus computer and my keyboard is set to American international it works perfectly.

all the best

raypen 04-17-2008 03:07 PM

You seem to be missing the point. I don't really care whether or not
'the 'Shift' Key or 'Caps Lock' is on, I can get around that.

The main concern is that the function keys do not work under the
so-called "Legacy USB" or simply USB support. I indicated previously
that I thought they may simply not be defined in the BIOS USB
support. I have read that sometimes USB BIOS support can be somewhat
limited. I have tried to find information relating to this but none
seems to be available and my attempt to ask the motherboard mfg.
about it has met with silence.

I can still, however, use my PS/2 keyboard where the function keys
seem to work just fine. I am assuming that my BIOS USB support implies
the use of "60/64 emulation", whereby scan codes from my USB keyboard
are translated to proper PS/2 codes and placed in the PS/2 data area
where they can be read by the keyboard controller. Just for yucks, I
booted into Linux and used 'showkey' to output the function key scan
codes. The codes produced by the USB keyboard are identical to those
produced by the PS/2 keyboard. I don't know if this means the USB
keyboard outputs identical codes (probably) or there is some translation
to PS/2 codes which is what 'showkey' is revealing. It doesn't really
matter as the proper codes are output by either keyboard. This would seem
to imply that the function keys should work, regardless of the keyboard used.

The only thing I can think of now, is that maybe "60/64 emulation" is
not being used but the scan code output from the USB keyboard is simply
the same as PS/2. However, if the BIOS USB keymap (if there is a separate one)
is lacking the code for the function keys, that would explain why they
do not work.

I'm afraid I'm not really sure how all of this works and would welcome
any information on USB support with Phoenix Technologies Award Modular BIOS
v. ABA41 1/3/01 on an FIC AD-11 motherboard.

All times are GMT -5. The time now is 09:40 PM.