LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 04-20-2008, 10:10 AM   #1
donquixote1
Member
 
Registered: Aug 2007
Posts: 94

Rep: Reputation: 15
USB Flash stick not recognized in Suse 10.3


I've got a simple 2Gb Peak USB2.0 stick, that works perfectly without any extra drivers in suse 10.3/kernel 2.6.22.17-0.1-default i686 and kde 3.5.9 "release 57.3" (just to be clear about my OS), now I bought an Adata USB flash drive van 8Gb, it's just "flickering", but that's all.

When I use the command # mount I have the following information for my 2Gb USB-stick with the other information as well of course as:
/dev/sdc1 on /media/disk type vfat (rw,nosuid,nodev,noatime,flush,uid=1000,utf8,shortname=lower)

When I insert this 8Gb flash USB stick into the same USB port and I use the command # mount I just see the usual information but no information nor any data for the 8Gb flash USB stick.

It's funny, because I inserted this 8Gb flash stick into a USB port with one of neighbours, using WinXP, and it was working perfectly.

This means that neither my USB port (the 2Gb stick is working) nor the 8Gb flash stick (working under WinXP) have a hardware problem. Moreover Adata states on its site that the 8Gb flash USB stick should be working properly for Kernel version 2.4 and later without any drivers.

How can I get my suse 10.3/kernel 2.6.22.17-0.1-default i686 sofar, so that my 8Gb flash USB will be working, my 2Gb USB stick is under /dev/sdc1 (same USB port anyway). What should I configure or change in which file anyway to have the 8GB flash USB work properly?

I hope someone knows the solution. Thanks anyway.
 
Old 04-20-2008, 05:31 PM   #2
lambchops468
Member
 
Registered: Mar 2007
Location: New Jersey, USA
Distribution: Archlinux
Posts: 165

Rep: Reputation: 30
show us the output of "lsusb" (you may need to be root)

do it both with the 8GB flash drive plugged in and not plugged in.

also, show us the output of "dmesg | tail -n 20"

after you plug the flash drive in.
 
Old 04-20-2008, 06:18 PM   #3
donquixote1
Member
 
Registered: Aug 2007
Posts: 94

Original Poster
Rep: Reputation: 15
with 8GB flash drive plugged in:
# lsusb
Bus 005 Device 002: ID 1307:0165
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000

8GB flash drive not plugged in:
# lsusb
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000

output:
# dmesg | tail -n 20
usb 5-8: Product: USB Flash Drive
usb 5-8: Manufacturer: USB 2.0
usb 5-8: SerialNumber: b08355536547f5
usb 5-8: configuration #1 chosen from 1 choice
scsi3 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
scsi 3:0:0:0: Direct-Access USB 2.0 USB Flash Drive 0.00 PQ: 0 ANSI: 2
sd 3:0:0:0: [sdc] 15794176 512-byte hardware sectors (8087 MB)
sd 3:0:0:0: [sdc] Write Protect is off
sd 3:0:0:0: [sdc] Mode Sense: 00 00 00 00
sd 3:0:0:0: [sdc] Assuming drive cache: write through
sd 3:0:0:0: [sdc] 15794176 512-byte hardware sectors (8087 MB)
sd 3:0:0:0: [sdc] Write Protect is off
sd 3:0:0:0: [sdc] Mode Sense: 00 00 00 00
sd 3:0:0:0: [sdc] Assuming drive cache: write through
sdc: sdc1
sd 3:0:0:0: [sdc] Attached SCSI removable disk
sd 3:0:0:0: Attached scsi generic sg4 type 0
usb-storage: device scan complete

the same information with my 2GB USB stick in the same USB port:
plugged in:
# lsusb
Bus 005 Device 004: ID 1307:0163
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
not plugged in:
# lsusb
Bus 005 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
output:
# dmesg | tail -n 20
usb 5-8: Product: Flash Drive
usb 5-8: Manufacturer: PEAK III
usb 5-8: SerialNumber: 7754ae00b310e9
usb 5-8: configuration #1 chosen from 1 choice
scsi5 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 5
usb-storage: waiting for device to settle before scanning
scsi 5:0:0:0: Direct-Access PEAK III Flash Drive 0.00 PQ: 0 ANSI: 2
sd 5:0:0:0: [sdc] 4030463 512-byte hardware sectors (2064 MB)
sd 5:0:0:0: [sdc] Write Protect is off
sd 5:0:0:0: [sdc] Mode Sense: 00 00 00 00
sd 5:0:0:0: [sdc] Assuming drive cache: write through
sd 5:0:0:0: [sdc] 4030463 512-byte hardware sectors (2064 MB)
sd 5:0:0:0: [sdc] Write Protect is off
sd 5:0:0:0: [sdc] Mode Sense: 00 00 00 00
sd 5:0:0:0: [sdc] Assuming drive cache: write through
sdc: sdc1
sd 5:0:0:0: [sdc] Attached SCSI removable disk
sd 5:0:0:0: Attached scsi generic sg4 type 0
usb-storage: device scan complete

Hope we can solve the problem for the 8GB flash drive now. Thanks.

Last edited by donquixote1; 04-20-2008 at 06:38 PM.
 
Old 04-22-2008, 11:16 PM   #4
lambchops468
Member
 
Registered: Mar 2007
Location: New Jersey, USA
Distribution: Archlinux
Posts: 165

Rep: Reputation: 30
sorry I was seriously sick for the last few days.

It seems the kernel and udev see your drive fine.

did you try a manual mount?

mount /dev/sdc <some directory>
 
Old 04-22-2008, 11:38 PM   #5
manojkumar.ges
LQ Newbie
 
Registered: Apr 2008
Posts: 1

Rep: Reputation: 0
Linux installation in 2 gb compact flash drive

Hai,

I am using 2 gb kingston 2 GB | 266 X. I tried SUSE 10.3 live cd & DVD.
But i failed.

pls give any idea.

It is possible in any other linux distributions.

Regards
Manoj
 
Old 04-23-2008, 02:25 PM   #6
donquixote1
Member
 
Registered: Aug 2007
Posts: 94

Original Poster
Rep: Reputation: 15
for lambchops468: I indeed did a manual mount /dev/sdc1 and possibly further, but it says: cannot find it in /etc/fstab or /etc/mtab, whereas when I plug in my 2Gb USB stick into the same USB port it says: /dev/sdc1 already present or /media/disk busy, according to mtab /dev/sdc1 os already present on /media/disk, but for the 8Gb flash USB it does not do anything. And I told, plugged into WinXP this 8Gb flash USB works perfectly. My front USB port works fine with my 2Gb USB stick, my bluetooth stick, my digital camera and so on, not with the 8Gb stick, what can we do to connect this flash perfectly now? By the way, there are no drivers, not for Win not for Mac not for Linux. It should work fine. Thanks.

Last edited by donquixote1; 04-23-2008 at 02:26 PM.
 
Old 04-24-2008, 09:10 PM   #7
lambchops468
Member
 
Registered: Mar 2007
Location: New Jersey, USA
Distribution: Archlinux
Posts: 165

Rep: Reputation: 30
donquixote1: ok, to remedy your manual mount, you must first specify a mount point for which to mount the flash drive. That error is usually because when you specify just the device node, mount goes to /etc/fstab to look for an entry that states the mount point.

you could do this:
Code:
mkdir /media/usbstick
mount /dev/sdc1 /media/usbstick
the file system should be automatically detected (unless its ntfs).

when you tried to mount your 2GB flash drive, it returned that message because the drive was already mounted via the automounter (udev). it placed an entry in the /etc/mtab file.

Last edited by lambchops468; 04-24-2008 at 09:20 PM.
 
Old 04-24-2008, 09:14 PM   #8
lambchops468
Member
 
Registered: Mar 2007
Location: New Jersey, USA
Distribution: Archlinux
Posts: 165

Rep: Reputation: 30
Quote:
Originally Posted by manojkumar.ges View Post

I am using 2 gb kingston 2 GB | 266 X. I tried SUSE 10.3 live cd & DVD.
But i failed.

Manoj
Did you try a manual mount?
 
Old 04-25-2008, 02:15 PM   #9
donquixote1
Member
 
Registered: Aug 2007
Posts: 94

Original Poster
Rep: Reputation: 15
# mkdir /media/usbstick is correct but then with # mount /dev/sdc1 /media/usbstick, first I saw: you have to indicate a file system, after (not with the 2Gb stick, that was correct with this syntax): special /dev/sdc1 does not exist, so what can I do next, a system?
 
Old 04-25-2008, 04:06 PM   #10
lambchops468
Member
 
Registered: Mar 2007
Location: New Jersey, USA
Distribution: Archlinux
Posts: 165

Rep: Reputation: 30
Quote:
special /dev/sdc1
was this exactly the message?

Either the flash drive wasn't recgonized this time, or the file system needs to be specified...

it may be ntfs. nfts isn't supported for automount.

mount -t ntfs-3g /dev/sdc1 /media/usbstick
 
Old 04-26-2008, 02:38 AM   #11
donquixote1
Member
 
Registered: Aug 2007
Posts: 94

Original Poster
Rep: Reputation: 15
This is what I get:
# mount -t ntfs-3g /dev/sdc1 /media/usbstick
NTFS signature is missing.
Failed to mount '/dev/sdc1': Invalid argument
The device '/dev/sdc1' doesn't have a valid NTFS.
Maybe you selected the wrong device? Or the whole disk instead of a
partition (e.g. /dev/hda, not /dev/hda1)? Or the other way around?
By the way, I also tried with hda and hda1, but without result.
 
Old 04-26-2008, 12:20 PM   #12
lambchops468
Member
 
Registered: Mar 2007
Location: New Jersey, USA
Distribution: Archlinux
Posts: 165

Rep: Reputation: 30
The funny thing is that your kernel does see your drive but we can't get it to mount.
What file system are you using (I should have asked this a while ago)
 
Old 04-26-2008, 01:43 PM   #13
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
  • Do you have the vfat module loaded? " lsmod | grep vfat
    vfat 30336 1
    fat 70832 1 vfat"
  • After inserting the disk, is there a /dev/sdc1 node created? "ls /dev/sdc*"
  • What does "sudo file -s /dev/sdc" say?
  • Look at the output of "udevinfo -q env -n /dev/sdc".
    Look for lines like:
    ID_FS_USAGE=filesystem
    ID_FS_TYPE=vfat
    ID_FS_VERSION=FAT32
    ID_FS_UUID=4B6E-6BC0
  • Check the usb relate kernel modules:
    Code:
    lsmod | grep usb
    usb_storage           102944  4
    ide_core              165648  1 usb_storage
    usbcore               156456  4 usb_storage,ehci_hcd,ohci_hcd
    scsi_mod              176536  6 sr_mod,sbp2,usb_storage,sg,sd_mod,libata
  • If the file command indicates you are using the NTFS filesystem, the make sure the ntfs kernel module is loaded. "modprobe ntfs". Or install the "fuse" and "ntfs-3g" packages. Then you can use the "ntfs-3g" filesystem enabling read/write access.

Last edited by jschiwal; 04-26-2008 at 03:43 PM.
 
Old 04-27-2008, 12:41 PM   #14
donquixote1
Member
 
Registered: Aug 2007
Posts: 94

Original Poster
Rep: Reputation: 15
# lsmod | grep vfat - I got nothing
# locate vfat
/lib/modules/2.6.22.17-0.1-default/kernel/fs/vfat
/lib/modules/2.6.22.17-0.1-default/kernel/fs/vfat/vfat.ko
/sbin/fsck.vfat
/sbin/mkfs.vfat
/usr/share/man/man8/fsck.vfat.8.gz
/usr/share/man/man8/mkfs.vfat.8.gz
/usr/src/linux-2.6.22.17-0.1-obj/i386/bigsmp/include/config/vfat
/usr/src/linux-2.6.22.17-0.1-obj/i386/bigsmp/include/config/vfat/fs.h
/usr/src/linux-2.6.22.17-0.1-obj/i386/debug/include/config/vfat
/usr/src/linux-2.6.22.17-0.1-obj/i386/debug/include/config/vfat/fs.h
/usr/src/linux-2.6.22.17-0.1-obj/i386/default/include/config/vfat
/usr/src/linux-2.6.22.17-0.1-obj/i386/default/include/config/vfat/fs.h
/usr/src/linux-2.6.22.17-0.1-obj/i386/xen/include/config/vfat
/usr/src/linux-2.6.22.17-0.1-obj/i386/xen/include/config/vfat/fs.h
/usr/src/linux-2.6.22.17-0.1-obj/i386/xenpae/include/config/vfat
/usr/src/linux-2.6.22.17-0.1-obj/i386/xenpae/include/config/vfat/fs.h
/usr/src/linux-2.6.22.17-0.1/Documentation/filesystems/vfat.txt
/usr/src/linux-2.6.22.17-0.1/fs/vfat
/usr/src/linux-2.6.22.17-0.1/fs/vfat/Makefile
/usr/src/linux-2.6.22.17-0.1/fs/vfat/namei.c
# ls /dev/sdc*
/dev/sdc /dev/sdc1
# sudo file -s /dev/sdc
/dev/sdc: x86 boot sector, Microsoft Windows XP MBR, Serial 0x4dd5721
# lsmod | grep usb
usb_storage 80908 0
ide_core 122948 1 usb_storage
hci_usb 20124 0
bluetooth 57172 5 rfcomm,l2cap,hci_usb
usblp 17024 0
usbcore 124268 7 usb_storage,hci_usb,usblp,hsfosspec,ehci_hcd,uhci_hcd
scsi_mod 140376 5 usb_storage,sr_mod,sg,sd_mod,libata

Well this is what I got for you, I think there's something with 8Gb flash with Microsoft Windows XP MBR, correct or not? Please advise what I could do next to make the 8Gb flash work properly now.

Thanks.
 
Old 04-29-2008, 10:53 PM   #15
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678Reputation: 678
run "sudo /sbin/modprobe vfat".

Also make sure you don't have "noacpi" as one of the kernel boot option. Without acpi, dbusd and hald won't work so automounting of external drives won't work either.

If you know which device an external drive is you can run:
sudo file -s /dev/sda1
for example to examine the filesystem on the device. It will tell you if it is a fat32 or ntfs. If you won't be using it in windows consider reformating the drive in the ext2 or ext3 filesystem. ( for flash drives, maybe ext2 would be better because ext3 uses journaling which may increase the number of writes to the device. )

Last edited by jschiwal; 04-29-2008 at 10:57 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
USB Flash stick boot yosemite Linux - Software 3 03-07-2007 01:27 PM
usb flash memory stick HeyAZ Fedora 2 08-21-2006 09:34 PM
USB memory stick not recognized Filip Viorel Linux - Hardware 1 03-29-2006 01:50 AM
How do I mount a USB flash memory stick? brian Linux - Newbie 3 02-07-2004 02:49 PM
USB Flash Disk not recognized Alphi Linux - Hardware 10 06-16-2003 05:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 02:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration