LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   USB flash memory??? (https://www.linuxquestions.org/questions/linux-hardware-18/usb-flash-memory-103340/)

perdesiz 10-13-2003 04:53 AM

USB flash memory???
 
I am using MDK 9.1 and I wonder if there exist any easy way to mount the USB flash memory stick I have...

iainr 10-13-2003 05:17 AM

I had no problems with a flash memory pen. I just plugged it into the USB port and, with Mandrake 9.1, it mounted it as /mnt/removable and there is was, ready for me.

Iain.

andutt 10-13-2003 05:32 AM

Your usb device will appear as a scsi device, you chould be able to see what the system is calling it in /proc/scsi. With fdisk -l you should be able to see which kind of filesystem exists on the usb-device. It should be named like sd1,2,3 or something.

frogman 10-13-2003 06:06 PM

plug it in

type (possibly as root, depending on your setup)

mount /dev/sda1 /mnt/removable

remember to umount /dev/sda1 before you unplug

toegrim 10-15-2003 08:32 AM

In trying to contact my RedHat Linux 9 machine to my usb storage pen I was adviced to log on as su - and type cd /mnt/usb-pen and then type ls. This did only get me root@localhost usb-pen, but no visible content on the connected pen. I then tried mount /dev/sdb1 /mnt/usb-pen, but the machine tells me mount: /dev/sdb1 is not a valid block device. I then try modprobe /usb-storage with no other result than root@localhost root. I then try mount /dev/sdb1 /mnt/usb-pen getting me the old /dev/sdb1 is not a valid block device. After this I exit out of su -. I would be very grateful if someone could tell me if there is hope for my USB-pen on Linux.

aurelio 10-15-2003 08:52 AM

usbdrive
 
I tried to mount usbdrive via shell script but always system gives me an error.
I put usbdrive in /etc/fstab but system do not mount it again.
Only after I login and issue a command mount -a , usbdrive
is mounted.
Anyone knows how to have a usbdrive mounted using a script?
My usb drive filesystem was created with:
mke2fs -j -m0 /dev/sda1

My script is this as root:

#!/bin/sh
make -p /datadir
for device in /dev/sda1 /dev/sda2 /dev/sda3 \
; do
mount -t ext3 -o ro $device /datadir
if test $? -eq 0
then
e2fsck $device -y
mount -t ext3 -o rw $device /datadir
fi
done


Mount complains /dev/sda1 is wrong file system, bad block
or too mounted filesystem when booting but when I
issue the same mount after login, usbdrive mount !

Could anyone help me?
Thank you in advance.

efmar 03-12-2004 11:10 AM

Usb Flash memory problem
 
I have a problem with my USB FLASH Memory on Suse Linux 8.2.

It was working as it should by mounting with the command: $ mount /media/sda1,
and then it was possible to read and write to the USB flash memory.

But then, once I forgot to do $ umount /media/sda1
and unpluged the device without umounting.

Since then it won't mount and gives the following error:

/dev/sda1: No such file or directory
mount: /dev/sda1 is not a block device (maybe try `-o loop'?)

Can anybody help me with this.

Thanks

Marija


All times are GMT -5. The time now is 11:01 PM.