LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Usb flash disk read-only problem (https://www.linuxquestions.org/questions/linux-hardware-18/usb-flash-disk-read-only-problem-163577/)

Darthomir 03-28-2004 09:19 PM

Usb flash disk read-only problem
 
Hello. I have a Pine USB 2.0 Flash Drive.
I can mount it into /mnt/flash, I see all the data, everything is fine.
But I cant write to it, it tells me that its in read-only mode!
It is supposed to be a FAT32 partitions.
So I go check in /dev
Do a $ls -l sda1 (my usb), I see it.
Here are the permissions I see:
brw-------
I see that I can write, but I wonder for the b!
Is it related to binaries or whatsoever?
Thx to help me!
Max

michaelk 03-28-2004 09:26 PM

The b stands for block device which is what a disk drive is.
Device permissions are different then the mount permissions.

For a user to write to a FAT32 partition you will need to add umask=000 option to the /etc/fstab entry. For details just search the website.

Darthomir 03-30-2004 09:30 PM

Ok I'll do a better search using the info u provide me!
Thx!
Max

Darthomir 03-31-2004 07:51 PM

But by putting it into the fstab, does it need (the memory stick) to be in the usb slot when booting? Or this is just a conf file used whenever I insert it?
Thx,
Max

michaelk 03-31-2004 08:07 PM

Some RH or FC1 experts will need to pipe in if FC1 installs with automounting.

If you do not include the noauto option then the OS will attempt to mount the filesystem at boot regardless of the stick being inserted.

Darthomir 04-02-2004 09:29 PM

Ok I played around an I have some issues..
If I edit fstab with the USB not in the slot, I dont see the line /dev/sda1. But the line where it says about /dev/sda1 shows up in the fstab when I actually put the USB in the slot (like if this line on the fstab appears only when I do put the USB! so whenever I modify it under root, it reset to the default when I put it back!)
So here is the line that "appears" whenever I put the USB:
/dev/sda1 /mnt/flash auto noauto,owner,kudzu 0 0
And the permissions for flash
drwxr-xr-x
Ok I am supposed to be able to write when Im a user, but here is the problem: the user seems to be root, not the user mounting the USB!
So following this website I made a new dir in /mnt, called mems. I used their command, # mkdir -m 777 /mnt/mems, I see that it has all the permissions, fine.
But I cant edit fstab since that freakin line reappers whenever I put the USB in the slot, I try modifying it, saving it, but never save actually. I did try to change it in the /etc/mtab, but whenever I try to mount it, it says that in the fstab its not the same folder.. or "according to mtab, /dev/sda1 is already mounted on /mnt/mems" which is false! .. AH!!
Please help! ;-)
Thx,
Max

michaelk 04-03-2004 09:04 AM

Take kudzu option out and add umask=000 option to the fstab entry.

BTW You do not want to modify the mtab file.


All times are GMT -5. The time now is 03:11 PM.