-   Linux - Hardware (
-   -   USB external drive: NTFS/FAT32 detected, ext3 not (

blanks77 04-25-2006 07:23 PM

USB external drive: NTFS/FAT32 detected, ext3 not

I looked around and it seems partitions have caused a lot of people problems, but I couldn't find one like mine:
I have a dual boot system, WinXP and FC5, and I also have an external USB drive. On my external, I have 2 partitions. One is NTFS, and the other I use for testing. I was able to mount the NTFS partition onto Fedora (using the kernel module appropriate for my kernel version). Now, the other partition, when I format it as FAT32, it is detected automatically and I can access it from Fedora (no surprise there, Linux can read/write drives of FAT format). However, when I format that partition as Ext3, Ext2, or Reiser FS, it does not appear anywhere in Fedora.

I do my partitioning work in Windows with Acronis Disk Director. Could that be part of the problem? I have even tried formatting that partition as "None". No matter what file type I format it as, it does not appear in Fedora, unless it's a FAT type of some kind, or NTFS.

Any help would be much appreciated.

Brian1 04-25-2006 07:49 PM

I would remove the partition and then under fedora create it again and set it as linux partition. Then format it under linux.


Brian1 04-25-2006 07:50 PM

Re read it again. What does the command as root ' /sbin/fdisk -l ' report.


blanks77 04-25-2006 08:06 PM

Hello Brian,

Thanks for replying. The output of that command is:

Disk /dev/hda: 100.0 GB, 100030242816 bytes
255 heads, 63 sectors/track, 12161 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 5224 41961748+ 7 HPFS/NTFS
/dev/hda3 5225 5237 104422+ 83 Linux
/dev/hda4 5238 12161 55617030 8e Linux LVM

Disk /dev/sda: 300.0 GB, 300069052416 bytes
255 heads, 63 sectors/track, 36481 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda2 * 2 36481 293025600 f W95 Ext'd (LBA)
/dev/sda5 2 35177 282551185 7 HPFS/NTFS
/dev/sda6 35178 36481 10474348+ b W95 FAT32

EDIT - I forgot to mention that I have formatted that second partition as NTFS and merged it with my first partition, also NTFS. I have only NTFS and FAT32 on my external at the moment. Should I attempt to format the second partition as Ext3 and run the command again?

Brian1 04-25-2006 08:17 PM

So I guess you want to change /dev/sda6 to ext3 correct?
If so then use the command as root ' /sbin/fdisk /dev/sda '
Hit ' t ' for type, select partiton' then type ' 83 '
Hit ' w ' to write and save.
Run command ' /sbin/mkfs.ext3 /dev/sda6 '


blanks77 04-25-2006 08:25 PM

Apparently it worked, given the console's reply.
But now, when I click that drive (which now appears, so that's an improvement), Konqueror gives me "Failed to mount device." That doesn't sound right, I don't need to mount ext3 drives correct?

EDIT - I restarted Fedora, the drive appears, 10GB drive label, that looks ok, but NOW when I click it, Konqueror says "An unknown error occurred."

Brian1 04-25-2006 08:42 PM

How are you mounting it?
What is your mount command?
Do you have a line in /etc/fstab for it?
basic would like this.
create a directory in /mnt and name it say /mnt/sda6
Then the mount command ' mount -t ext3 /dev/sda6 /mnt/sda6 '


blanks77 04-25-2006 08:45 PM

Yes, my folder in mnt is called ext3
My command is this:
mount /dev/sda6 /mnt/ext3 -t ext3 -r

All times are GMT -5. The time now is 08:57 PM.