-   Linux - Hardware (
-   -   USB dongle on dreamplug (for sending SMS) (

eantoranz 08-27-2012 07:54 PM

USB dongle on dreamplug (for sending SMS)
Hi, guys!

I'm doing experiments to send SMS with a USB dongle (huawei, just in case) on a dreamplug. First things first. When I connect the dongle to my x86 box, I get 3 new serial USB ports. Then I can use the first of these 3 new ports to send AT commands to the dongle (think of it as a modem). I tried the same thing with a beagleboard and the same thing happend... but I'm connecting the dongle to the dreamplug and I see stuff in dmesg about it but no serial devices that I could use to send the AT commands..... so, what do I have to do so that the serial ports do show up on the dreamplug? Do I have to use a different kernel? And if so, where can I see how to build/install it on the dreamplug?


# uname -a
Linux sheevaplug-debian #1 PREEMPT Tue Feb 8 03:18:41 EST 2011 armv5tel GNU/Linux
# cat /etc/debian_version
# lsusb
Bus 001 Device 006: ID 12d1:1446 Huawei Technologies Co., Ltd. E1552 (HSPA modem)
Bus 001 Device 004: ID 0d8c:000c C-Media Electronics, Inc. Audio Adapter
Bus 001 Device 003: ID 05e3:0726 Genesys Logic, Inc.
Bus 001 Device 002: ID 1a40:0101 TERMINUS TECHNOLOGY INC. USB-2.0 4-Port HUB
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

From dmesg:

usb 1-1.2: new high speed USB device using orion-ehci and address 5
scsi2 : usb-storage 1-1.2:1.0
scsi3 : usb-storage 1-1.2:1.1
scsi 2:0:0:0: CD-ROM            HUAWEI  Mass Storage    2.31 PQ: 0 ANSI: 2
scsi 3:0:0:0: Direct-Access    HUAWEI  MMC Storage      2.31 PQ: 0 ANSI: 2
scsi 2:0:0:0: Attached scsi generic sg2 type 5
sd 3:0:0:0: Attached scsi generic sg3 type 0
sd 3:0:0:0: [sdc] Attached SCSI removable disk
sr0: scsi-1 drive
Uniform CD-ROM driver Revision: 3.20
sr 2:0:0:0: Attached scsi CD-ROM sr0

Thanks in advance.

eantoranz 08-28-2012 01:27 AM

Could it be a missing mapping in modules.usbmap?

eantoranz 08-28-2012 09:51 AM

Ok..... so I sat down with my box and the dreamplug in front of me to see what's going on.

There's a mapping to module "option" in both modules.usbmap however, when I insert the dongle on the dreamplug, option module is not loaded..... I tried modprobing it but not much happened... damn!

What's next?

All times are GMT -5. The time now is 06:37 AM.