-   Linux - Hardware (
-   -   USB devices died after USB hub install (

Twistedlizzard 07-04-2005 07:09 AM

USB devices died after USB hub install
Hello everybody...

I'm running suse 9.1 on my HP XE4100 notebook. The notebook comes with 2 USB1 ports as standard... so I went and bought myself a 4 port USB hub. That's when everything went wrong:

I plugged the hub in, and it caused some sort of conflict because now none of my USB ports are working at all. My USB mouse is dead, my external DVD burner is dead, even my USB bluetooth adapter!!! It's definitely not the ports either because when I boot the system with the mouse plugged in, the optical light goes on, then off again when suse starts it's bootup processes... and it's dead once the system is up and running... please can anybody help!!!

Twistedlizzard 07-04-2005 07:40 AM

Just to add some new info... using the boot install disk, choosing the manual install option:

I load the USB modules, and choose the "boot installed system" option and the mouse is suddenly working... but when I boot using the standard bootup... nothing. can anybody give me the command line to manually load / start the usb modules?

fouldsy 07-04-2005 05:26 PM

What USB modules are running when you have you USB port plugged in and boot the laptop normally? Try running "lsmod | grep usb" and see what it displays. With my 4 port USB hub plugged in, one of my lines is:

usbcore 104676 6 ehci_hcd,usblp,usbhid,ohci_hcd

telling me I have 6 ports available (which is correct: my 4-port hub, plus 2 other USB ports). Have a look and see if you are getting the right number of ports. Otherwise, type "dmesg" and read through the lines on loading USB devices. SuSE 9.1 is 2.6.4 kernel as stock, yes? It should show you stuff like:

hub 1-1:1.0: USB hub found
hub 1-1:1.0: 4 ports detected

as it loads up the USB modules, then starts to work out what devices you have.

Have you tried unplugging all other USB devices and seeing at which stage it fails to boot? It might be a particular device doesn't like running through the hub. I've known USB scanners not play nicely running through a hub (maybe due to the power they draw?).

Twistedlizzard 07-05-2005 06:17 AM

ok, I've taken the hub out, plugged just my mouse into one of the ports and booted up normally, the mous is dead and running lsmod | grep usb returns:

usbserial 29168 0
hci_usb 12544 0
bluetooth 46180 6 12cap,hci_vhci,hci_uart,hci_usb
usbcore 103644 5 usbserial,uhci_hcd, hci_usb

so I ran dmesg and here's the lines I think might be linked to the cause:

ACPI PCI Interrupt 0000:00:11:2[D] -> GSI 11 (level, low_ -> IRQ 11

uhci_hcd 0000:00:11:2: UHCI Host Controller
irq 11: nobody cared!

Disabling RQ#11

hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected

usb 1-2: new low speed USB device using address 2

usb 1-2: control timeout on ep0out

It also looks like my on-board NIC isn't working, dmesg returns:

eth0: Transmit timed out, status 1003, PHY status 782d, resetting...
eth0: Setting full duplex based on MII #1 link partner capability of 45e1

So that's my 2 usb ports and my on-board NIC not starting up - all because I plugged a USB hub in???!?!!!

So I rebooted, this time with my external usb DVD drive plugged in, it booted my suse install DVD and I loaded the USB and NIC modules then booted installed system and everything is working again... so somewhere my config has changed to disable the devices in normal boot?

Twistedlizzard 07-08-2005 06:43 AM

Well, I decided to reinstall - after trying to sort it out I finally gave up and did a complete reformat and install... plugged the hub in, plugged my mouse, usb bluetooth adapter, plugged my external dvd burner in and booted up and they all work fine... I can now use my flashdrive, my digital camera and even my SD memory card reader using the hub no problems... still, it would be nice to know what the hell happened.

fouldsy 07-08-2005 07:17 AM

At least it's sorted. I don't know enough about how SuSE loads USB modules, but I guess the USB hub must want something else loaded that isn't created during the initial install unless it's already present, so the system can't load it automagically when you connect it. Glad everything works now though!

All times are GMT -5. The time now is 03:50 AM.