LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   USB Device not accepting address (https://www.linuxquestions.org/questions/linux-hardware-18/usb-device-not-accepting-address-211787/)

systemparadox 07-31-2004 08:34 AM

USB Device not accepting address
 
Hi,
I am trying to turn an old system into a server. My adsl modem is usb, so I have purchased a cheap 2 port usb 1.1 pci card from ebuyer. It seems to work (on linux) in a newer system I have available, but in the server system I keep getting errors like this on boot, when it tries to load the controller:
hub.c: new USB device 00:0b.0-1, assigned address 2
usb.c: USB device not accepting new address=2 (error=-110)
hub.c: new USB device 00:0b.0-1, assigned address 3
usb.c: USB device not accepting new address=3 (error=-110)

I think the motherboard is a VX Pro, which I am told is a Via Apollo VP-1. It has four pci solts and three isa solts. The only cards in the system are a graphics card (in the top pci slot), a network card (in the second PCI slot) and the pci usb card.

I did manage to stop the boot errors by removing the network card and putting the usb card in the 4th slot. However, when I plug a device into the usb card I get the same problem.

I have tried changing some bios options, but that has made no difference.

I am running Slackware 9.1 (kernel 2.4.22).

Thanks in advance
Simon

SomeGuy7898 07-31-2004 02:25 PM

That sounds a bit odd. There could be conflicts, but I have never seen any PCI conflicts like that before. Random idea, but you could try the 2.6.x kernel, and see what happens from there? As well, if its a server, the latest kernel is always a good security feature.

systemparadox 08-24-2004 11:00 AM

Ok- I'm having a lot of agro with the 2.6 kernel, whilst I am trying to fix that can anyone else help? I have read around and it appears to be more of a hardware/bios issue. The motherboard I am now trying to use is a PC Chips M572- I have updated the bios to the '24/02/99 S' version- I can't find anything newer than that, but there could easily be something, as the manufacturer has nothing about it on their website.

The depressing thing about this is that before the bios flash I could get the card itself not to give the errors on boot (any device plugged into it would then refuse to accept an address), now the two ports both fail to accept an address (now the same as the vxpro board).

I know the M572 has on-board usb, but I don't have a dongle for it.

PLEASE- SOMEBODY HELP ME- this is getting really depressing- I have been trying to get a server working for more than a year now :cry: :cry: :cry: I know it's almost certainly not a linux related problem but I'm really fed up- I have spent hours and hours googling on this- nobody seems to know anything. Anyone elso who has had this problem just moved the card to another slot and it worked fine- I've tried all sorts of things on three different motherboards and it still only works on my newest pc (which I can't use as a server).

Thankyou in advance- your help is greatly appreciated
Simon


All times are GMT -5. The time now is 04:18 PM.