LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   USB device hot plug failed sometime (https://www.linuxquestions.org/questions/linux-hardware-18/usb-device-hot-plug-failed-sometime-452327/)

raytzer_liao 06-07-2006 04:07 AM

USB device hot plug failed sometime
 
My system run RedHat AS3.0 U7 with kernel 2.4.22. There is a problem when I tried to plug a USB device(either a USB stick or USB floppy driver). The USB device won't work sometimes. And I saw below message.
usb.c: USB device not accepting new address=3 (error=-71)
usb.c: USB device not accepting new address=4 (error=-71)
usb.c: USB device not accepting new address=5 (error=-71)
usb.c: USB device not accepting new address=6 (error=-71)
...

Sometime, the device work and no such error when I plug the device.
Sometime, the device work but with some error message. I think the OS tried many time to hook the device, and finally it work.
Sometime, the device can't work, it push many error message, and stop trying.

Anyone have idea on it?

unSpawn 06-08-2006 01:31 PM

Yeah, USB can be flakey sometimes. I don't plug in storage devices until the system is fully up and accessable. Provided this is a "regular" setup (no capabilities taken away etc, etc) plugging in the device then loads the corresponding modules and running "devlabel restart" manually after that usually fixes things for me.


All times are GMT -5. The time now is 09:23 AM.