-   Linux - Hardware (
-   -   USB-CD/DVD writer problems with late 2.6 kernels (

ekman 12-27-2004 04:14 PM

USB-CD/DVD writer problems with late 2.6 kernels
I have an external CD/DVD burner attached with USB2 or Firewire. It works fine with
Fedora2 with 2.6.5-something kernel. With Fedora3 or Fedora2 with later kernel
(2.6.9) it does not work anymore.

I have searched the net for info and found that many has experienced similar
problems for kernels >2.6.7. "cdrecord -scanbus" gives weird results, and when trying
to burn, cdrecord hangs. So far I have not seen any explanation or solution published
anywhere, so I try to ask this forum.

With the recent 2.6.10 kernel "cdrecord -scanbus" works on my machines, but burning
still hangs. This line is repeated in the syslog;

SCSI error : <0 0 0 0> return code = 0x70000

after a long time (around 15 minutes) the burning continues and seems to be succesful
from the printouts, but the CD is corrupted. While crdecord hangs it can not be killed,
not even with "kill -9".

Since I can use USB or Firewire I have tried both. The result is about the same, which
makes me believe that the problem is in the SCSI emulation layer, or cdrecord's use

Any information about this problem is greatly appreciated.

Please note that this is about external USB/Firewire burners only! I can burn CDs
on an ide-internal burner without problems, so "hdc=ide-scsi" and alike will NOT
solve this problem.

Best Regards,
Lars Ekman

ekman 12-27-2004 04:17 PM

Oh, and I am running as "root" so this is not the known
"suid" problem with cdrecord.
L Ekman

xerakko 01-06-2005 07:01 AM

cd writer
I had the same problem with kernles 2.6.7, 2.6.8 & 2.6.9. It has been problem with 2.6.10 kernel

xerakko 01-06-2005 07:02 AM

I want to say It has been solved in 2.6.10 :)

All times are GMT -5. The time now is 07:29 AM.