-   Linux - Hardware (
-   -   USB bus not working (

jonmohr 07-11-2012 05:06 PM

USB bus not working
Every time I insert any usb device into my laptop, I get the error from usb 2-1 saying "device not accepting address x, error -62" where x is any number from 1 to 100. before that line, usb 2-1 also logs "new full-speed USB device number x using ohci_hcd"
Both of those lines will be logged indefinitely whenever any usb device is inserted, regardless of distro (tested on fedora 17 live and Mint 13 Cinnamon)
additional info: worked fine until yesterday and i have no idea what the device id of my usb hub is or whether or not it is a built-in motherboard hub or a PCI hub.

Pastychomper 07-17-2012 03:21 AM

I've had something similar in the past, in my case it was down to a dodgy USB port. Since it's only just started, maybe your cable/plug/port is getting a bit worn, or dirty.

Try running rmmod ehci_hcd as root - this disables USB 2, forcing the ports to work as USB 1.1, which is slower but more reliable.

There are more details and suggestions here.

jonmohr 07-18-2012 10:06 PM

I tried running that command in the terminal as root, and I got this response.
libkmod: ERROR ../libkmod/libkmod-module.c:1791 kmod_module_get_holders: could not open '/sys/module/ehci_hcd/holders': No such file or directory
Error: Module ehci_hcd is in use

business_kid 07-19-2012 03:11 AM

Put your error numbers into this command (instead of 62) to see what's going on

grep 62 /usr/include/asm-generic/errno.h
Then you can take those errors, and google them with ehci_hcd in the search term. Error 62 is timer expired, btw.

jonmohr 07-19-2012 11:56 AM

I tried the grep command, and it told me that there was "no such file or directory"

business_kid 07-19-2012 02:52 PM

Have you kernel headers installed?
/scratches head

Error 62 is timer expired, anyhow.

jonmohr 07-19-2012 10:07 PM

maybe I typed in the wrong command, but I got the reply "no such file or directory" I typed in /scratches head

aus9 07-19-2012 10:48 PM

scratches head = joke comment

can you post the output to your /var/log/dmesg pls to a site and link back to it
eg here is mine;lines=0

I changed mine to hide line numbers and 24 hr expiry but leave yours as is pls

that way we can see if a kernel module is playing up

jonmohr 07-21-2012 11:09 PM

^playing along.. I don't have a log for dmesg... (might be related to a distro switch to knoppix)

aus9 07-23-2012 10:17 PM

should not be....all previous tests I have done with knoppix have dmesg

ok how about .... /var/log/messages

now it may be huge if you do not have a nice logrotate config so instead try this

insert usb then run command


sudo tail -n 30 /var/log/messages
now that may only show if there is something wrong with your current usb device and not if a kernel module has not loaded

so have a look at

lsmod (and see if uhci* ehci* modules are loaded)

if they are not, I don't have usb3 spec usb name your device spec

then look at increasing the -n (number) to 200 but pipe it thru less so you page up and down


sudo tail -n 300 /var/log/messages | less
and if you think appropriate post that section showing usb devices being detected here is mine as example

good luck

All times are GMT -5. The time now is 11:27 AM.