-   Linux - Hardware (
-   -   usb audio - problem with midi and recording (

pgm30wh 01-13-2006 04:26 AM

usb audio - problem with midi and recording
Hi there!

I have a couple of problems with my usb sound blaster (Terratec 26 Phase usb) and a Suse 10.0.
The sound blaster is ok with system configuration: with kaffeine and amarok I can play sound. With Audacity, to make it works I need to launch it with OSS emulation (aoss audacity) otherwise the sound card is not detected.
Anyway, now I would like to record my sound: with audacity it crashes (because of a known bug), I tried with qaRecord (tried even as root) and I see the signal is sent to the system (the line indicating the level of input detect the sound, but a very low level) but when I save the audio file I record only silence.
I have noticed that with Alsamixer, The CAPTURE device is not detected (as I can't change the level of this).
More, I have a problem with MIDI: when playing a MIDI file both with Kmid, both with Kaffeine/Amarok, no sound is produced.
Does anyone have any suggestions?

Thank you

ramowl 07-01-2006 03:34 PM

Sounds to me like you want to do some "serious" recording.

Maybe what you need is a "serious" sound card.

Do some research on "professional sound cards." I'm using an M-Audio 2496 card.

ALSA works just fine for my needs. OSS will charge you for a license to get drivers that support professional audio cards.

Make sure you have JACK and its libraries installed. For more info on JACK check htt;:// If you purchased your copy of SuSE 10.0, you should already have all the files you need on your installation discs ;-)

You will have to run your recording applications under root privileges. Start JACK first, then start Audacity.

For more info on this check out the following links:

Hope this helps!

All times are GMT -5. The time now is 03:33 PM.