LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 03-12-2004, 02:05 PM   #1
hdagelic
LQ Newbie
 
Registered: Sep 2003
Location: Zagreb, Croatia
Distribution: rh9, debian
Posts: 28

Rep: Reputation: 15
us robotics sportster (pci) modem problems on mandrake 9.2 and 10


Hello !


I am having problems getting my modem work with mandrake. It's an internal pci hardware modem. Mandrake doesn't recognize it and I use setserial to assign I/O adress to the serial driver:

# lspci -v

here I find out what IRQ and I/O adress is set in the modem; ports 9000, IRQ 11


then i give a setserial command:

# setserial /dev/ttyS4 port 9000 irq 11 uart 16550A

and then link /dev/modem to /dev/ttyS4


And i believe that should be sufficient. After that the modem was working under debian, redhat and mandrake 9.0 but it's not working with mandrake 9.2 or 10.0. I echo an ATDT 039840 to /dev/ttyS4, and nothing happens, and kppp says "modem is busy".

Any suggestions ?


One more thing: irq 11 is already assigned to the graphics adapter and I'm unable to change it with "setpci". Does that matter ? I had a similar situation before and when I dialed in it was obvious that graphics performance decreased; windows that were being dragged around the screen were leaving trails !

And another one: Even when that modem is working there are problems with it - the first dialin after a reboot always results in error 16 "modem hangup". My friend told me that he was experiencing the same and he fiixed it, but he doesn't remember how
 
Old 03-12-2004, 02:41 PM   #2
hdagelic
LQ Newbie
 
Registered: Sep 2003
Location: Zagreb, Croatia
Distribution: rh9, debian
Posts: 28

Original Poster
Rep: Reputation: 15
Lightbulb

No need to bother with the first problem. I forgot that I dont have write permissions for /dev/ttys/4. I set it and it works. I'm using it now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install U.S Robotics Sportster , EXTERNAL medya Linux - Hardware 9 10-27-2005 09:32 PM
Will USR Sportster 56k Data Fax ISA modem work with linux? andrewstr Linux - Hardware 24 02-23-2004 09:52 PM
us robotics 56k pci voice and linux Aljaber Linux - Networking 2 12-30-2003 05:09 PM
US Robotics PCI modem & Linux Aljaber Linux - Hardware 1 11-18-2003 08:11 AM
Us Robotics Wireless PCI Card bruce1271 Linux - Wireless Networking 25 09-05-2003 09:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 08:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration