LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   unstable USB??? under console, not X. (http://www.linuxquestions.org/questions/showthread.php?t=4175483009)

kaz2100 11-01-2013 04:31 AM

unstable USB??? under console, not X.
 
Hya,

System
Debian jessie, current, amd64. Please check my HCL entry for detail. Memory is 4G (3654316 KiB)

Situation
If I leave this system under console mode (conventional login: prompt) for a while, keyboard dies, (LED goes off!!) Screen complains that no keyboard detected, bad cable(??).

If I kick in X timely manner, no problem at all.

So far
Reboot through remote login does not solve situation. Boootup message says "no keyboard".

Remove USB cable and connect again solves this situation.

I would like to try some other keyboard, but currently I do not have any.
Question
Where shall I go next?
Motherboard, keyboard, USB cable or memory????

I will appreciate any suggestion.

cheers

business_kid 11-01-2013 10:55 AM

keyboard or power settings. Also check plug into usb - the connector can get loose. does it change if you wiggle the plug?

kaz2100 11-03-2013 06:39 AM

Hya

Thanks for your reply.

USB plug looks OK.
I have not checked power setting.
Keyborad, I will find some other one.

cheers

lleb 11-04-2013 08:42 AM

have you tried other USB ports? sounds like either a PSU is going bad of your USB port is on the brink.

kaz2100 11-04-2013 08:51 PM

Hya,

Yes, I have tried two (maybe three) different USB ports, situation does not change. (All of them connected directly to motherboard, rear panel)

I have not tried ones on front panel, (connected via cable from middle of motherboard).

Thanks for your suggestion, I will update.

cheers

business_kid 11-05-2013 09:30 AM

If this is is getting to be a pain, you cancompile your kernel with usb debugving on. It will spew crap into the log about usb. You can run 'tail -f' and see what's going on.

Shadow_7 11-05-2013 10:22 AM

It sounds like a bad usb port. My old laptop developed symptoms on par, but not an exact match to yours. But I ran it over a year after the fan completely stopped working. When it started corrupting filesystems connected to it's usb, I retired it.

You might check and see if your motherboard has a firmware update. Those have fixed a few "other" issues with things for me over the years.

kaz2100 11-10-2013 02:13 AM

Hya

Thanks for replies.

update:
It looks like that one of four USB ports (connected directly to motherboard) looks good. (so far, no problem)

I will check firmware and will turn debugging on next time I compile kernel.

cheers.

business_kid 11-11-2013 02:23 AM

You can also be careful with your usb modules.

xhci_hcd is new, and can be a pain with certain devices and kernel versions still in use. That does 2.x/3.x afaict. I find it very finicky.
ehci_hcd is 2.x only but stable. If you do not have usb-3.x devices, this may solve it.
ohci_hcd & uhci_hcd are usb-1.x modules and do not co exist peacefully. use one or the other, depending on your chipset.

kaz2100 03-18-2014 07:56 PM

Hya

Apology for long interval. I had some sort of private problem.

I had both uchi and ohci. Now I have only ohci.

I will update.

thanks

cgtueno 03-28-2014 06:45 AM

Hi kaz2100

A further suggestion to those already offered.

May I suggest that you test the USB keyboard that you are using, on another working computer. It may be that the keyboard is drawing an excessively high current (ie. is faulty) and that you are tripping over current circuity associated with the USB ports.

I would suggest that you re-test your system with another known working keyboard, and if that doesn't work, then try installing a powered USB HUB between the keyboard and the USB ports that have presented the problem.
That would at least rule out inadequate current supply as a cause.

C.

kaz2100 03-29-2014 08:10 AM

Hya,

Thanks,

Yes, I checked my USB keyboard on two other computers. No trouble.

No, I have not checked another USB keyboard on that computer. I do not have any other USB keyboard. I have only legacy ones.

cheers


All times are GMT -5. The time now is 05:03 AM.