LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Unresolved symbol when trying depmod -a (https://www.linuxquestions.org/questions/linux-hardware-18/unresolved-symbol-when-trying-depmod-a-155769/)

Sarinyo 03-10-2004 07:00 AM

Unresolved symbol when trying depmod -a
 
Hello everyone. (First of all, sorry for my english!)

I've got P4C800 mobo, and I'm triyng to install onBoard LAN (yes the famous 3Com). I've read loads of posts talking about how to install it, and I'm trying but I've got no luck :-(. I try 3c2000 and sk98lin modules, and finally I decide to install the sk98lin module (it seems is best than the other). First I tried to use the 3c2000 driver. I can compile and load, but didnt work, I dont know why. So then, I went to syskonnect and I download the driver, actually is a script that compiles and install the module (I use rh9 with 2.4.20-8 kernel verison). But when I run the script, I obtain a warning while testing kernel headers. Everything else works fine. Then I add the entry "aliases eth0 sk98lin" to /etc/modules.conf, and type 'depmod -a'. Then I obtain an error:

depmod: ***Unresolved symbols in /lib/modules/.../net/sk98lin/sk98lin.o

Is this because of the previous warning? I assume that, so I decide to download new kernel version, and try again. Is this correct, I mean have I to download another kernel vesion, compile it and patch it with the sk98lin patch from syskonnect? Is there another thing I can probe?

Furthermore, something strange happens to my LAN: the LEDS are always off (but Im sure it works, I use it with win2k). I've read a post about this problem and it says I should disable all ACPCI (or sth like that) bios entries, and I did it but no luck :-( (Im sure the cable works, I probe it with another PC, and the OnboardLan option is enabled in the BIOS). Any idea?

PS: One more question, when should the LEDS be on, while booting the machine or when the eth is loaded?

I'm linux newbe, and I would like my LAN works without trying another card.

Tnks guys!

jailbait 03-10-2004 11:30 AM

"depmod: ***Unresolved symbols in /lib/modules/.../net/sk98lin/sk98lin.o"

This message and the compile warnings probably mean that your kernel compile did not compile in some kernel module that sk98lin.o needs to link to. Take a look at the compile error messages and they may give you a clue as to what is missing.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites

Sarinyo 03-11-2004 05:58 PM

Tnks guy...
 
Tnks for reply, but actually I finally get it! I have to use the 3c2000 driver (the syskonnect one doesn't work, I cannot obtain more information from the warning, only says "Testing linux kernel headers" (or sth like this) and then it says "warning" (insted of "passed"), the other tests work fine), and have to fill in IRQ and I/O range manually (I obtained from /proc/pci, I think, I don't remember exactly), and then I've to change the cable, it doesnt work on this computer, but works fine in another one, I dont understand that, but now the important thing is my LAN works.

Tnks again, if I got more time, I try to install the sk98lin module!


All times are GMT -5. The time now is 04:25 PM.