-   Linux - Hardware (
-   -   Unable to write to hardrive from windows computer - uber newb (

violettheconqueror 09-23-2005 04:16 PM

Unable to write to hardrive from windows computer - uber newb
I found a similar thread "cannot access 2nd hard drive " but it did not answer all my questions. The story is: i just got a "new" computer, its actually quite old but its new to me, i installed mandrake 10.0 on its existing hd, i then added a hard drive from my last computer which was running windows 2k at the time, but had also been edited on an XP system. My computer reads the hard drive fine, i can access all the files, as far as i can tell, the problem is that i cannot change anything on it, i cannot delete any files, also, i cannot change the ownership (either through the consol or the KDE interface) and i cannot change the read\permissions. through the kde all i get is a "cannot delete" message, with the consol i get "rmdir: mandrake': read only file system" i tried quite a few things and am now convinced that i need to convert something in the hd, i am a complete newb, and am not a computer genious by any means, ive heard of somethng like FAT32 or something, i dont remember but i think i need to change that, how would i go about doing that, if its the prob, if not what is the problem, thank you.

niztec 09-23-2005 04:38 PM

Your windows HD is most likely formatted with an NTFS file system. The default module for access NTFS partitions in Linux only allows read only access. There is an expirmental read/write module I don't know how stable it is. I would download that module and install it. Like this link says ntfs write support is still expirimental and could destroy your filesystem.

Andrew Benton 09-23-2005 04:41 PM

How has the partition been mounted? Or to put it another way, what does it say in /etc/fstab?

violettheconqueror 09-23-2005 05:19 PM

/dev/hda1 / ext3 defaults 1 1
none /dev/pts devpts mode=0620 0 0
/dev/hda6 /home ext3 defaults 1 2
/dev/hdc /mnt/cdrom auto umask=0,user,iocharset=iso8859-1,codepage=850,noauto,ro,exec 0 0
none /mnt/floppy supermount dev=/dev/fd0,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,sync,codepage=850 0 0
/dev/hdb1 /mnt/windows ntfs umask=0,nls=iso8859-1,ro 0 0
none /proc proc defaults 0 0
/dev/hda5 swap swap defaults 0 0
none /mnt/hd supermount dev=/dev/ide/host0/bus0/target1/lun0/part1,fs=ext2:vfat,--,umask=0,iocharset=iso8859-1,kudzu,codepage=850 0 0

is what it says in /etc/fstab. also, with the experimental module, the information on this drive is somewhat important and would be very hard to replace, so what kinda dangers are associated. also, i dont know how file systems work but can i just change the file system to something linux likes instead of trying to read the current one? like just reorganize the files already in there? thanks

shamrock_uk 09-23-2005 06:54 PM

If the data is important don't touch that NTFS driver with a bargepole - seriously!

The solution you are looking for lies with the rather wonderful Captive NTFS, a nifty utility that uses Windows' own NTFS driver to allow safe write access to the drive. I'd still take a backup, just in case ;)

Oh, and just FYI, this line in your /etc/fstab file referred to your windows drive:


/dev/hdb1 /mnt/windows ntfs umask=0,nls=iso8859-1,ro 0 0
The 'ro' option mounts the drive read-only - removing it allows write access to Linux-supported filesystems.

All times are GMT -5. The time now is 08:44 AM.