LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   unable to mount hard drive (https://www.linuxquestions.org/questions/linux-hardware-18/unable-to-mount-hard-drive-641735/)

marcusnerison 05-12-2008 04:45 PM

unable to mount hard drive
 
when i click on my hard drive in konkourer this is the message i get



security policy in place prevents this sender from sending this message
to the recipient see message bus configuration file
(rejected message had interface "org.freedesktop.hal.device.volume"
member "mount" error name "(unset)" destination "org.freedesktop.hal")

phantom_cyph 05-12-2008 05:00 PM

What distro? What groups are you a part of?

GrapefruiTgirl 05-12-2008 05:05 PM

Without knowing what Linux distro you are using, and without formatting or punctuation of any kind in your post, it is difficult to help you; however, I will venture a guess that you need to do a bit of configuring in your HAL and/or DBUS rules or config files.

Depending on your Linux setup, this may also have something to do with PAM or SELinux, both of which are well out of my range of experience.

Cheers,

Sasha

jschiwal 05-12-2008 06:18 PM

Please put your distro in your user profile. There is one quick and easy thing to check. Look at the kernel boot options. If you have the "noacpi" boot option, then the hal and dbus daemons won't run. This is something that can cause automounting to not work.

Besides your distro, please verify that you are running kde. Is this a removable or a fixed drive?
Is the partition you are trying to open in konqueror exist in /etc/fstab? What is the filesystem used? Does your distro use the PolicyKit package?

marcusnerison 05-14-2008 12:26 PM

im not in any groups and the distro is backtrack 3 but i dont know anything about reprogramming and what not i just installed it two weeks ago i would like to figure out how to wipe my hard drive completely and reinstall it also in more than half the programs it only runs in the shell they dont have their own gui any help would be much appreciated

jschiwal 05-15-2008 12:12 AM

This is a live distro! If you will be working in the terminal you could use the "mount" command to mount your hard drive.

Look at the output of "sudo /sbin/fdisk -l" to see what partition exist. If you don't know the filesystem that a partition uses, you could use "sudo file -s /dev/<device>" to tell you. Then create a mount point; "mkdir /mnt/home" for example.
Suppose your home partition is on /dev/sda5 and it uses the ext3 filesystem. You could use:
sudo mount -t ext3 /dev/sda5 /mnt/home
to mount it.
See the "man mount" manpages for details on the mount command. When using konqueror you could try entering "man:mount" in the address bar.

marcusnerison 05-15-2008 06:35 AM

i have it installed though, i use it as my main operating system, also i cant change the screen res from i think its like 640 400 or sumthin , becasue of the screen res i cant press ok on half my programs which makes my computer pretty much useless

jschiwal 05-15-2008 06:51 AM

Check your xorg.conf file. Do you have higher resolutions listed? Also check the /var/log/xorg.0.log file and see if there were problems with the higher resolutions. If the virtual terminal resolutions could be higher as well, add "vga=791" to your kernel boot options in grub's menu.lst or lilo.conf. There is also the "gtf" program to create a modeline if you need to, ex:
gtf 1280 1024 60 -x

There is an xorg.conf manpage which explains this file.

marcusnerison 05-15-2008 01:03 PM

im sorry but i didnt understand anything you said what program do i open to use those commands and how do i read whats wrong?

marcusnerison 05-16-2008 01:12 PM

it mounts only if i boot frokm the disk but if i run it from the hard disc it wont mount i just want to be able to access the hard disc and play cds at the same time

jschiwal 05-17-2008 06:44 AM

You could test out the "vga=791" kernel boot option when you boot up. Simply add it to the end of the line of options in grub. You need to be root to edit /boot/grub/menu.lst. Open up a terminal and use sudo before your editor name, such as:
sudo vim /boot/grub/menu.lst
or
sudo nano /boot/grub/menu.lst

or in kde or gnome you can use kate, or gedit or your favorite text editor.
kdesu kate /boot/grub/menu.lst
or
gnomesu gedit /boot/grub/menu.lst

Code:

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 10.3 - 2.6.22.17-0.1
    root (hd0,5)
    kernel /boot/vmlinuz-2.6.22.17-0.1-default root=/dev/disk/by-id/scsi-SATA_FUJITSU_MHU2100_NQ07T4825B7P-part6 vga=0x317 nolapic resume=/dev/sda2 splash=silent showopts
    initrd /boot/initrd-2.6.22.17-0.1-default

Your entry will look different. I highlighted the vga= part.

When xorg starts, a log is created. Sometimes a problem will be indicated in the log. Look at "ls -l /var/log/Xorg*" and select the most recent log file if there is more than one. You can use less to read it:
less /var/log/Xorg.0.log

Press the "/" key and enter "EE" (without the quotes). A line that starts with (EE) is an error.

Also look at your /etc/X11/xorg.conf file:
less /etc/X11/xorg.conf

One of the sections is for the monitor configuration. If the timings are off that can cause problems:
Code:

Section "Monitor"
    Identifier    "Monitor[0]"
    VendorName    "HP"
    ModelName      "ZV5000"
    UseModes      "Modes[0]"
    DisplaySize    332    207
    HorizSync      32.0 - 48.0
    VertRefresh    40.0 - 70.0

    Option        "CalcAlgorithm" "XServerPool"
    Option        "DPMS"
EndSection

Also look at the section for your video card:
Code:

Section "Device"
    Identifier    "Device[0]"
    Driver        "nvidia"
    VendorName    "NVidia"
    BoardName      "GeForce4 440 Go 64M"
    Screen          0
EndSection

My laptop uses an nvidia card. I downloaded an installation program from nvidia and ran it as root in a virtual terminal after running "sudo /sbin/init 3" to make sure the xorg server wasn't running. If you have a different card, such as ATI then you need a different driver. Your distro may have a graphical setup for this, but often, accelerated video drivers need to be downloaded because they tend to be propriety.

The screen section contains the resolutions that you want to run:
Code:

Section "Screen"
    Identifier    "Screen[0]"
    Device        "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    Option        "AllowGLXWithComposite" "True"
    Option        "RenderAccel" "True"
    Option        "AddARGBGLXVisuals" "True"
    SubSection    "Display"
        Depth      15
        Modes      "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection    "Display"
        Depth      16
        Modes      "1280x800" "1280x768" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection

If yours just has "800x600" then that could be the problem.
Before the 1280x800 resolution became more common, I needed to create my own modeline for this resolution.
Code:

gtf 1280 800 60 -x

  # 1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz
  Modeline "1280x800_60.00"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync

I added the line:
Code:

  Modeline "1280x800_60"  83.46  1280 1344 1480 1680  800 801 804 828  -HSync +Vsync
to my [Monitor] section and then added "1280x800_60" entries in the screen section.

The xorg.conf file has a man page which explains what each section does. If possible you might want to print it out:

man -t xorg.conf | lpr

--

Also indicate which video card your computer uses.

marcusnerison 05-17-2008 04:29 PM

this is so confusing i am just gonna grab another harddrive and start over with ubuntu or something


All times are GMT -5. The time now is 12:35 PM.