-   Linux - Hardware (
-   -   Unable to mount dvd device on Fedora (

corpus_delicti 01-02-2004 10:58 PM

Unable to mount dvd device on Fedora
I am becoming very frustrated with trying to mount my dvd device. I know Fedora detects this as /dev/hdc and is linked to by /dev/cdrom because of the start up. However, if I try "mount /dev/cdrom /mnt/cdrom" i get "mount: no medium found". Also, if i try to open a dvd in mplayer i get "no medium found". When I try these commands my LED light on the dvd drive does not even light up.

I think this problem goes deeper than the O/S too because I cannot open disks in this drive Win XP either.

Any help is greatly appreciated...
Thank you in advance

acid_kewpie 01-03-2004 03:16 AM

well despite the very implicit message, you've not actually confirmed you have ANYTHING in the drive......

corpus_delicti 01-03-2004 10:28 PM

perhaps you would like me to attach a photograph of a disk inserted in the drive...

i would appreciate someone with help, not some anal person being nit-picky about details

johnallen 01-04-2004 12:32 AM

Is your CD-ROM drive a CDRW & DVD combo?

if not..

Do you have a seperate cdrom drive from your dvd drive that is listed as /mnt/cdrom

I also had issues with getting dvd play back in Fedora. I use a combo drive and I had to tell mplayer to look at /mnt/cdrom instead of /mnt/dvd. After I make this change everything worked.

adz 01-04-2004 02:53 AM

Try just a mount /mnt/cdrom. That relies of there being an appropriate line in you /etc/fstab file which is more oftern than not put in by default. If that fails try a mount -t is09660 /dev/hdc /mnt/cdrom. If that fails (and you're sure your drive is /dev/hdc) then rest assured I've had some problems with DVD drives before. Is there any difference between mounting a regular data CD and a DVD (ie does one work an the other not work)? Also how are you invoking mplayer?

Osclay 01-04-2004 09:04 AM

I have the same problem with fedora. My DVD cd r/w combo by LG is one of two cd devices. Fedora just does not want to play any data dvd, most of the time, but every now and again it plays one, say about one in 10. the device is listed as cdrom1 and the basic cd as cdrom. Fstab seems to be correct. Redhat 9, Suse 8.2 and Mandrake have no problems with it Sorry no solutions but more info that might help some expert

corpus_delicti 01-04-2004 09:48 AM

No... my DVD drive is seperate from my CD-RW.
My CD-RW is /dev/cdrom1
and i tried several mount options, mount /dev/hdb, mount /dev/cdrom, mount /dev/dvd, and nothing worked. I've tried everything and I'm afraid my DVD drive is broken. I'm just going to try a friend's drive and see if it works. Thanks for the help

melovesjava 01-31-2004 02:33 AM

a newbie solution
I was able to watch movie on fedora core 1 with 2.4.22-1.2149.nptl kernel. I have a seperate dvd and cd rom drive. I did following to watch the movie
1) Mount my dvd drive , i used mount /mnt/cdrom
2) Make a soft link ln -s /mnt/cdrom /dev/dvd
3) Start Xine for command line
4) Right click xine, and choose paylist and then dvd
Thats it!!

corpus_delicti 02-03-2004 09:40 AM

actually everything is fine now, it was actually my dvd drive dying on me, thanks anyway

All times are GMT -5. The time now is 01:50 AM.