LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   unable to mount cd rom drive (https://www.linuxquestions.org/questions/linux-hardware-18/unable-to-mount-cd-rom-drive-167046/)

m_boots 04-06-2004 07:17 PM

unable to mount cd rom drive
 
Hi,
I am unable to mount my cdrom drive.
My fstab looks like
-----
LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda8 swap swap defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 ro,noauto,user 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 ro,noauto,user 0 0
/dev/fd0 /mnt/floppy auto 0 0
-------
when I do
> mount -t iso9660 /dev/cdrom /mnt/cdrom
mount: block device /dev/cdrom is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
or too many mounted file systems

Are my links messed up?
[root@localhost murty]# ll /dev/cdrom*
lrwxrwxrwx 1 root root 8 Apr 4 18:24 /dev/cdrom -> /dev/hdd
lrwxrwxrwx 1 root root 9 Apr 4 18:24 /dev/cdrom1 -> /dev/scd0

- Do I need to change the links and/or fstab. If yes please help what and how should I modify
- why am I getting a read only message error and how do I get rid of it.
- Also is there a way I can auto mount the drives (I have two cd drives) so that I do have to mount it whenever I login or something?
I've got crazy trying to get this to work and help will be really appreciated

Marty

win32sux 04-06-2004 07:45 PM

well, the read-only message is because you can't really "write" to a cd-rom...

=)

can't tell why it's failing to mount the cd, though... a few questions:

you sure the cd is fine???

it's not a music cd or something like that, right???

also, make sure there isn't something mounted at that spot already...

m_boots 04-06-2004 07:51 PM

hehe thanks for correcting
Actually it is a music CD. How do I play it then.
Thanks

win32sux 04-06-2004 07:59 PM

you access the songs directly from the device file...

like, with xmms, you just make sure you have a cd-reading plugin enabled, and then you just tell it to look for the songs in /dev/cdrom or whatever device file represents your cd-rom drive...

also, if you enable the cddb plugin, you'll get the titles for all the songs and stuff...

m_boots 04-06-2004 08:22 PM

I tried using xmms and nothing happened. Do you think the links (in my first append) has anything to do with this. Also how do i have a cd-reading plugin enabled?

m_boots 04-06-2004 08:38 PM

I tried using the alsa player and then I try to play /dev/cdrom and it says no stream. When I eject and put the cd back again KsCD comes up and when I try playing it the time on the player says 73:22 and starts decreasing (like it would increase when playing a CD) but I hear no sound. I have sound configured I guess because I can hear the test sound.
I am like really on the verge of getting sound!!!! have been trying from a long time...
someone pls help.....

m_boots 04-06-2004 08:50 PM

Do I need to change permissions anywhere or something? Also do I need to configure any audio plugin (I'm asking this because with xmms in options->preferences you can configure i/o plugins. However I am unsure about the options....if someone can go over this step by step with me it would be a BIG help!!!!

win32sux 04-06-2004 08:54 PM

in xmms configuration/preferences there's a section for configuring your "input plugins"... one of the plugins should be the one for reading cd audio... make sure it's enabled...

your xmms works, right??? i mean, you CAN listen to mp3s... just not cds (yet)... right???

m_boots 04-06-2004 09:40 PM

Yes I can play mp3's in the alsaplayer, but not in xmms. This is what happens
If I am root I get this
[root@localhost murty]# xmms&
[root@localhost murty]# mcop warning: user defined signal handler found for SIG_PIPE, overriding
/tmp/mcop-murty is not owned by user
[root@localhost murty]# ls /tmp/mcop-murty/
Arts_AudioManager localhost_localdomain-0fe3-4071f988
artsd-samples localhost_localdomain-1db8-4071f007
Arts_MidiManager localhost_localdomain-1dbd-4071f03d
Arts_PlayObjectFactory localhost_localdomain-1dc1-4071f04a
Arts_SimpleSoundServer localhost_localdomain-1dc5-4071f05f
Arts_SoundServer secret-cookie
Arts_SoundServerV2

If I am a user and I bring up xmms and try to play an mp3 nothing happens. I have all plugins enabled (though I'm not sure why the CD Audio Player 1.2.7 p[ugin is disabled each time I restart xmms)

Atleast mp3s on alsaplayer works!!! now if only I get audio cds to work

m_boots 04-06-2004 10:01 PM

Ok..some more progress...now I can play mp3s with xmms when a user. I still get the same error as above when I try playing as root...

win32sux 04-06-2004 10:18 PM

if you're using alsa, make sure the output plugin on xmms is set to alsa...

why on earth would you want to run xmms as root???

m_boots 04-06-2004 11:00 PM

The output plugin for xmms is set to eSound Output Plugin 1.2.7.
Now I can play mp3's with both xmms & alsa....playing audio cd's remains...


All times are GMT -5. The time now is 06:05 PM.