-   Linux - Hardware (
-   -   Unable to get HP Laserjet wireless Printer 100% functional (

trafficman 05-05-2012 09:45 AM

Unable to get HP Laserjet wireless Printer 100% functional
I just bought a HP Laserjet P1102w wireless-enabled printer an unfortunately I haven't been capable of using it wirelessly and even on USB doesn't always work.

I run Ubuntu 10.02 recetly upgraded to 12.02 and the issue persists.

Basically the printer only works via USB and only after resetting it and I have to do this every time I use the printer after it has gone to sleep mode or I had restarted my computer.

The wireless connection has never worked, I try to set it up with the HP-Config wizard connected to USB when the printer is being recognised but I get the following error:

An I/O error occurred.
Please check the USB connection to your printer and try again.
(Device I/O error)

I have noticed the printer doesn't have an IP address attached to it since the IP address on the printer self-test page comes up as 0.0.0.

I tried installing HP-lips trough different methods (Ubuntu Software Center, Donwloading and unpacking and using the installation wizard) I have reinstalled and installed at least four times an get the same results everytime, have red several posts around and haven't found anyone with a similar problem as it seems that for most people the printer either work or doesn't.

Quite stuck right now, if anyone could help me to find the path to solve this I will be deeply grateful.



frankbell 05-05-2012 08:46 PM

Here's what the Linux printing database has to say:

I assume you have verified that the USB port and cable are okay.

Here's a suggestion as regards the wireless function: Try giving the machine a fixed ip address and then trying to set it up over the network. Test whether you can ping it; if so, try to configure it with HPLIP. The printer manual should tell you how to give it an ip address. If you don't have the manual, you likely can download it from HP.

I recently had an issue setting up a known-fully-functional-under-Linux wired network HP printer. On the particular computer, hp-setup could not discover the printer, but when I passed the printer ip address to hp-setup, it connected flawlessly. See man hp-setup for information on how to do that.

trafficman 05-06-2012 06:20 AM

Hi Frankbell,

Thanks for your reply.

Yes, I did the Linux Database Suggested instalation once again and still have the same problem.

I suspect if I give the printer an IP address then everything is going to be easier as you well said.

However setting up an IP address hasn't been a walk in the park so far... Here is what happens:

When I print a self-test page from the printer the IP address comes as 0.0.0 which I assume means no IP address exists at all.

The wireless blue led blinks when I switch on the wifi anntena buttom, perhaps because there is no IP address the printer is not connectable.

I tried to manually edit the DCHP.conf file which apparently is where you assign IP addresses to all the things in the network, I added this right at the end:

host localhost{
hardware ethernet 2C768A02BEB2;

Where the long number is the Hardware Address that comes out in the self-test page (AKA MAC address) and is an IP address I assigned since my router has the

Then restarted after this modification and still my printer's IP is 0.0.0 so this is obviously not the route to make it happen.

Step 2:
Unintalled driver from CUPPS and HP-lips and did the whole process from the begining again, this time I tried to manually assing a ipp://HP_LaserJet_Professional_P1102w?serial=000000000Q93A9ZESI1c address to my printer from CUPPS to see if HP-Config recognizes as a network computer.. the result: NADA

Step 3: Opened the router via browser to see if I can discover the printer that way, unsurprisingly there is nothing there.

DO you or anyone reading this knows a reliable way to assing an IP address to a wireless printer?

Again, thanks! this is being difficult

frankbell 05-06-2012 07:08 PM

I'm afraid I can't help. My HP has a menu setting on its little display window that allows me to set the IP address. You enter the IP address and the printer configures the settings from there.

If you don't have the manual, I think you can get it here:

All times are GMT -5. The time now is 09:12 PM.