-   Linux - Hardware (
-   -   ubuntu / linux bluetooth connection issues (

mrmnemo 07-18-2010 02:04 PM

ubuntu / linux bluetooth connection issues

this is a repost of my thread here about the issues I have been having with a bluetooth gps device.
All info about the system / debug logs can be found in the above referenced post. As to my issue, I can get the connection paired. I can get rfcomm to stream data from the device. I can connect gpsd -b to the /dev location. I can not seem to get xgpsd or any other application to read from gpsd.
I have been told that this is a bluetooth issue and not a API issue with gpsd - 3rd party application. If anyone else has a functioning bluetooth connection ( this only seems to affect gps devices ) that works using the latest stable blueZ stack please let me know. I just cant seem to get it working.

Thanks for checking in!

onebuck 07-19-2010 07:09 AM


Why fragment things into a different thread? It seems you were doing fine within the referenced post.

Find out why bluetooth is an issue for you. Keep it within the original so as not to confuse everything.

bluetooth gps on linux - short howto might help.


tredegar 07-19-2010 08:25 AM


Why fragment things into a different thread?
... Because I asked him to: His original thread refers to tangogps & gpsd when I think his problems are bluetooth-related. So, new problem, new thread.

mrmnemo 07-19-2010 11:50 AM

new idea

Originally Posted by onebuck (Post 4037979)

Find out why bluetooth is an issue for you. Keep it within the original so as not to confuse everything.

bluetooth gps on linux - short howto might help.


thanks! i did not try linking the /dev/rfcomm to a serial port! Thats a new approach that may fix it. If it works i will post in one chunk what worked. Odd thing is...i would have thought that gpsd could talk to /dev/rfcomm directly?? o well, thanks again guys. I put this post up due to a suggestion. Feel free to move it back.

heviiguy 07-21-2010 11:41 AM

Can't even get NMEA stream to flow (Issue and Resolution)
May I butt in?

I have similar issues, yet perhaps more fundamental: I can't even get NMEA data to flow. Here's my output...

heviiguy@hevii-NtBk-1:~$ telnet localhost 2947
Trying ::1...
Connected to localhost.
Escape character is '^]'.

Tango reports that there is no gps nor gpsd.

I've checked to see whether the GPS available
hcitool scan
Scanning ...
00:0D:B5:35:D8:BC BT-GPS-35D8BC

I've bound gpsd to rfcomm0
gpsd /dev/rfcomm0

I've killed gpsd
sudo service gpsd stop

I've restarted gpsd
gpsd -b -n /dev/rfcomm0

xgps shows:

It's driving me (hah, a good pun!) nuts.

Background: I'm running a Global BT-GPS-35D8BC. It operates fine as an external GPS on my mobile phone as well as on Windoze 7. In fact, I've re-set it to factory defaults using SiRFDemo on the latter.

UPDATE : This is just too bizarre - I just cleared the BT-GPS from the bluetooth device manager, reconnected and... voila: xgps shows my position, Tango shows my position, and, OpenCPN does as well! Now I just have to get the known issues with gpsdrive and gpsd on Ubuntu 10.04 resolved!

Yeah, I've got the option of not sending this message since I no longer have a problem but, maybe if it's up here it'll help somebody else.

heviiguy 07-21-2010 12:02 PM

No changes made : Problem has returned!
I had mentioned bizarre in the previous post. I have to mention it again: I'm faced with the same problems as before... :banghead:

I cannot get gpsd to communicate with the BT-GPS

Tango was running while I was busy doing something else. At one point, I noticed that the BT icon in my panel suggested that nothing was connected. Sure enough, when I checked Tango, my position was gone.

I restarted Tango. No joy.
I started xgps. No joy
I shutdown Bluetooth
I cleared the BT-GPS from the list of devices
I found and added it again.
Started Tango. No joy
Started xgps. No joy

I can see that for the past 5 minutes, my Bluetooth connection is still active.

Any suggestions? All are welcome and actively sought! I'd really like to get this annoying situation resolved.


heviiguy 07-21-2010 12:39 PM

Changed the Bluetooth dongle
In case I may have had a defective USB Bluetooth dongle, I took out one and replaced it with another. Same story!

However, now my active rfcomm is 1 instead of 0! It's not my place to ask why. I just went ahead and changed all references to 1.

Same darn problem.:scratch:

tredegar 07-21-2010 01:03 PM


heviiguy@hevii-NtBk-1:~$ telnet localhost 2947
The current version of gpsd no longer supports the telnet option, because it has been extensively rewritten over the last year.

See the gpsd homepage, which will explain this (and more).

If you lose your BT connection to your gps device, and it is later re-established, it may be allocated to /dev/rfcomm1 instead of /dev/rfcomm0. In which case gpsd will be listening to a non-existant device: you'll have to kill gpsd and restart it with the curent /dev/whatever

IMHO bluetooth and GPS are a PITA with linux at the moment.

My USB connected GPS device works very reliably.

My impression of BT is that it's a bit like USB on linux six years ago: It worked, but you had to fight with it all the time.

Maybe linux's handling of BT needs a little time to "catch up".


mrmnemo 07-21-2010 04:46 PM

outside of configuration issues ( very possible) caused by forcing rfcomm to bind to a device that seems to hop channels everytime it is re-paired.i am with tredgar in thinking it may be an issue with blueZ and gpsd. If it was an api issue between gpsd and tangogps then i think the xgps that is packaged with gpsd ( current for buntu repos ) I would see something from the device. Anyhow, been busy with another issue regarding video ( something simple I think ) and have put the bluetooth on the back burner. I will try changing it again soon.

heviiguy 07-22-2010 10:27 AM

Bluetooth and Linux : Simply roll over and die?
Thanks for your reply, Tredegar. Being a newb to the entire Linux world, I suppose that I should accept the sage comments. However, is this really the case?
  • Is nobody experiencing satisfactory functionality with bluetooth gps devices on Linux?
Please, somebody out there must have developed some weird and fancy ways to get this stuff working together! I can't believe that the massive community of Tango, Viking, gpsdrive and OpenCPN users out there are only "getting by" through constant battling and struggling :(

mrmnemo 12-19-2010 01:42 PM


This is an older thread i started. I solved my gps over bluetooth here. Hope it helps. The solution is on the last page of the thread.

All times are GMT -5. The time now is 07:14 AM.