-   Linux - Hardware (
-   -   Ubuntu is running in low graphics mode and Ubuntu stops booting (

Ubuntu213 02-21-2011 09:14 AM

Ubuntu is running in low graphics mode and Ubuntu stops booting
I have Ubuntu 10.10 and when I boot my PC I can see the following message: Ubuntu is running in low graphics mode and Ubuntu stops booting. I can-t boot in it I can only use command line.
I think I accidentally uninstalled some packages clicking at completelly removal at some ipod utillities in synaptic. How can I fix this?
Your help is sincerelly appreciated


{BBI}Nexus{BBI} 02-21-2011 04:28 PM

What happens if you type:

? If you get your desktop you need to use the tool under System--> Administration to (re)install the driver for your graphics card. Once that is done reboot your system to see if the problem is now resolved.

Arno_H 04-05-2011 04:11 PM


I have exactly the same problem, also when trying to uninstall iPod utilities. As a matter of fact, the X window crashed during the uninstallation. When rebooting the computer, I got exactly the same "Ubuntu is running in low graphics mode" message. When typing the command "startx", I get a black screen with only a mouse pointer in it. I checked and can run apt-get and dpkg in command line mode. But all the checks give no errors and the problem remains. What is the command line for re-installing the graphics card?

Thanks in advance,


Ubuntu213 04-06-2011 05:54 AM

Hi, Finally I was able to fix it a few days ago. I'm sorry about not having post the solution yet.
Here it comes:

If you use Nvidia:

sudo apt-get update
sudo apt-get upgrade
sudo nvidia-xconfig

If this doesn't work try to change your download server in order to re-download all updates (Administration -> Update Manager -> Ubuntu Software -> Download from)

If you use Tor repository disable it (I don't know if this have to do with the problem but I did before solving it).

If you don't use Nvidia edit /etc/X11/xorg.conf as root instead of typing "sudo nvidia-xconfig".

Hope it helps.

Arno_H 04-09-2011 10:34 AM

Hello Ubuntu213,

Thanks for the help. I could install the upgrades with apt-get without any problem. However, the shell did not recognize the command nvidia-xconfig, neither xconfig, neither xorg. I tried to see if they were available with apt-get, but they were not. And the file xorg.conf did not exist in /etc/X11. I then loaded up Ubuntu from my boot CD to see what the /etc/X11/xorg.conf file looked like on my CD booted file system and it was not present either. I don't know what happend with the installation of the X window server on Ubuntu 10.10, but I can't seem to find any of the normal comnands.

So I am still in trouble,

Ubuntu213 04-11-2011 03:26 AM

Which distro do you use?

EDDY1 04-11-2011 03:40 AM

nvidia-xconfigure creates backup xorg.conf & new, but command isn't available unless you install nvidia.

Arno_H 04-11-2011 02:41 PM

Thanks for the help guys.

I am using Ubuntu10.10 desktop, with a nVidia ION VGA (rev b1) VGA compatible controller. I tried installing the nvidia package with sudo apt-get install nvidia, but it couldn't find the package.

EDDY1 04-12-2011 01:49 AM

Available through synaptic & 3rd party drivers. Have to add non-free to repo's.

Arno_H 04-25-2011 09:50 AM

Hello Eddy1

Thanks for the help, but I ended up backing up my system and re-installing it. This solved the problem of X-windows not starting. I then had to install the kubuntu desktop and then re-install the Ubunto gnome desktop to solve my problems. The system is now running fime again. But I still don't have an xorg.conf file in my directory /etc/X11.

Anyway, the problem has been solved.

All the best,


EDDY1 04-26-2011 12:35 AM


But I still don't have an xorg.conf file in my directory /etc/X11.
It not insttalled by default , because every thing is supposed to auto detect.

All times are GMT -5. The time now is 11:03 AM.