-   Linux - Hardware (
-   -   ubuntu graphic card error (

shakira19 04-07-2013 09:37 PM

ubuntu graphic card error

when booting with ubuntu 12.04, I sometimes get a huge error that prevents me from getting to the log in screen. The error window I get is this one (though the image isn't mine, I'm not running a VM:
I think this is due to my graphic card (nvidia 680 gtx). I have the recommended (proprietary) driver.
The log files can be found here

Can you help me figure out what's wrong please ?

GlennsPref 04-08-2013 12:15 AM

Hi, the open source nvidia module is loaded early in the start process.

You may have to blacklist it and edit (/etc/X11/xorg.conf)then reboot before you can get it to not load before X


blacklist nouveau
check video module is loaded and or reinstall the package.

shakira19 04-09-2013 01:11 AM

Thanks for your answer.
I'm sorry I really don't understand what you're talking about, I'm new to linux and I have no idea what you're talking about.
Could you give further details, in precise steps, as to what I am supposed to attempt, and the possible associated risks ?

Thank you.

TobiSGD 04-09-2013 08:01 AM

What GlennsPref is trying to explain is that your system is for whatever reason configured to use two drivers for the videocard at the same time (the proprietary driver and the free driver), which, as you can see, will lead to problems. The solution is to prevent the free driver from loading. To do that create a new file blacklist-nouveau.conf in the directory /etc/modprobe.d (or use an already existing blacklist file, as suggested by GlennsPref) and add the line

blacklist nouveau
to it. Since you need root privileges to access that directory the easiest way for Ubuntu would be to open a terminal and start the texteditor with

sudo gedit /etc/modprobe.d/blacklist-nouveau.conf
Feel free to substitute gedit in that command with your favorite text editor, if you want. Save that file, then make sure that you have a valid xorg.conf file, this can easily be done with the command

sudo nvidia-xconfig
If you now restart the system your problems should be solved.

shakira19 04-09-2013 04:10 PM

Ok thanks for this explanation, it was easier to understand.
So I did just that, and I added the line
blacklist nouveau
to the file /etc/modprobe.d/blacklist-nouveau.conf, which I had to create.
I then wrote 'sudo nvidia-xconfig'. It said that no previous configuration was found, and thus a new one had to be created.
Then I rebooted.

But the problem is still there.

After rebooting once again, I was able to go straight to the login screen.
But this was already the case before the above-mentioned manipulation, my problem was that *only sometimes* did I have problems booting. Given your explanations, this randomness could be due to the fact that one driver is picked up over the other in some cases, making it impossible to boot.

So what else can I do from here ?


GlennsPref 04-09-2013 06:00 PM

Hi, It's seems strange,

but I generally have to reboot twice too,

and when I get the login screen I find I need to once again confirm that the nouveau driver is not loaded and that xorg.conf has not been reconfigured by an auto script someplace (dri/drm/dkms).

I think you'll find this the last hurdle.


sudo nvidia-xconfig

or edit the file manually,

vi /etc/X11/xorg.conf

find the listing for nouveau and edit it to say nv or nvidia as you have been trying.

Now startx, you should be off the loop.

p.s. thankyou to Tobi for explaining what I neglected.

shakira19 04-17-2013 02:50 PM

so... sorry for the delay, I don't restart the computer often, specially because I'm afraid it will stop working one day due to this issue...

in any case, the problem is still there. Here are the new logs:

GlennsPref 04-17-2013 05:38 PM

hi, can't extract archive.

TobiSGD 04-17-2013 05:53 PM

The problem in this case is not that the free driver is loaded, as it seemed to be the problem before, but that the proprietary driver module could not be found. Do you have made any changes to the system before this happened?

shakira19 04-17-2013 11:26 PM

GlennsPref: I think tobiSGD was able to do so, so please try again.
tobiSGD: No, not that I'm aware of. I recall having this problem on a fresh ubuntu installation.

TobiSGD 04-18-2013 03:55 AM

That is weird, sometimes the computer is finding the nvidia driver, sometimes it is not. Honestly, I have no clue what could cause such a behavior.

GlennsPref 04-18-2013 06:03 PM

I tried to dl and open with ark 3 separate times, says unrecognised ....

Too much trouble to fix blindfolded. I have most of the standard extractors, tar gzip bzip2.

wanna post the info in code tags instead?

GlennsPref 04-18-2013 06:25 PM

do you have "nokmsboot" on your kernel boot cli?

TobiSGD 04-18-2013 06:41 PM

I have just used tar to extract the archive, but anyways, I have re-packaged the log-files, you can download them here:

GlennsPref 04-18-2013 06:58 PM

Thank you, that worked. (???)
have you tried kernel cli param,


All times are GMT -5. The time now is 07:25 PM.