-   Linux - Hardware (
-   -   ubuntu 9.04 64bit and brother dcp-7030 cannot install driver (

Thane 04-13-2010 06:21 PM

ubuntu 9.04 64bit and brother dcp-7030 cannot install driver
Purchased a brother dcp-7030 laser printer after reading very positive web review/forum comments stating drivers were available from brother site. Unable to install cupswrapper driver successfully. Created /usr/share/cups/model directory as directed (and also a /usr/share/cups/dcp-7030 directory in case I hadn't quite understood the instructions) and then installed cupswrapper brother progs via synaptic. Cannot find a 7030 driver to install. Tried installing the driver from the brother site, but after downloading the .deb version and trying to install it, I get a wrong architecture msg. Checked and I have the 32 bit dependencies installed, which the brother site states are required. At a loss at present. Thanks in advance.

puntjuh 04-14-2010 11:58 AM

What error are you getting about the architecture ?

I have a Brother DCP-540CN myself, and have had it working on both my gentoo and mint machines (both 64bit) for 2 years now, both printer and scan function as they should.

Have you used the "--force-architecture" in your dpkg -i cupswrapper.deb installation?

I don't know if you've used this how-to:


For dpkg users:
1. Install the standard c library for 32bit applications (e.g. lib32stdc++6(Debian) or ia32-libs(Ubuntu))
2. Create some folders if it is required
2-1. Create /usr/lib/cups/filter if it does not exist.
Command1: mkdir /usr/lib/cups
Command2: mkdir /usr/lib/cups/filter

2-2. Create /usr/share/cups/model if it does not exist
Command: mkdir /usr/share/cups/model

3. Install the drivers using "--force-architecture" or "--force-all"option.

4. Copy brlpdwrapperXXX files under /usr/lib/cups/filter/ to /usr/lib64/cups/filter/
Command: cp /usr/lib/cups/filter/brlpdwrapper* /usr/lib64/cups/filter

5. Copy libbrXXXX files under /usr/lib/ to /usr/lib32/ if /usr/lib32 exists.
Command : cp /usr/lib/libbr* /usr/lib32/

combined with this url it should work.

Let me know if it doesn't, and some errors perhaps copied from shell.

Good luck!

Thane 04-14-2010 08:28 PM

Thanks for reply! -- I'll try it out and follow up.
Just saw your post puntjuh. Thanks. I'm in a bit of a bind time-wise tonight and tomorrow. I'll definitely try your suggestions out on Saturday and reply with my experiences. Many thanks.

Thane 04-14-2010 08:34 PM

quick followup
I have checked and I definitely do have the following directories - /usr/lib/cups/filter /usr/lib/cups /usr/lib/cups/filter /usr/share/cups/model . I'll try out the "force" options and reply to your post on Saturday. Thanks again.

Thane 04-17-2010 04:12 PM

still hung up at the following point
sudo dpkg -i --force-all cupswrapperDCP7030-2.0.2-1.i386.deb
dpkg - warning, overriding problem because --force enabled:
package architecture (i386) does not match system (amd64)
(Reading database ... 147390 files and directories currently installed.)
Preparing to replace cupswrapperdcp7030 2.0.2-1 (using cupswrapperDCP7030-2.0.2-1.i386.deb) ...
* Restarting Common Unix Printing System: cupsd [ OK ]
Unpacking replacement cupswrapperdcp7030 ...
Setting up cupswrapperdcp7030 (2.0.2-1) ...
ERROR : Brother LPD filter is not installed.
cp: `/usr/lib/cups/filter/brlpdwrapperDCP7030' and `/usr/lib64/cups/filter/brlpdwrapperDCP7030' are the same file
chmod: cannot access `/usr/local/Brother/inf/brDCP7030rc': No such file or directory
chmod: cannot access `/usr/local/Brother/inf': No such file or directory
* Restarting Common Unix Printing System: cupsd [ OK ]

puntjuh 04-18-2010 04:24 AM

Did you install the LPR driver as well? prior to installing the cupswrapper driver?

If you haven't install the LPR installer from the Brother site, then reinstall your cupswrapper driver.

If you're uncertain check with "dpkg -l | grep Brother".

I will try following your steps on my sis's Ubuntu installed pc. And see if I experience the same issues.

Thane 04-18-2010 09:49 AM

Thanks puntjuh for your help! Just saw your last 2 posts. I had been working on the problem and solved it for myself. You were entirely correct in my not having first installed the LPR driver. Have been making up an installation procedure for myself in case I need to reinstall for some reason. Here it is. Thanks again!

Using the Brother website procedure from for 64 bit Ubuntu 9.04 v. 2.6.28-18 , in step #2 open For Debian/Ubuntu 64bit. The two requirements listed should already have been installed by Ubuntu - ia32-libs or lib32stdc++ ( lib32stdc++6 in my case). In step #3 open the DCP7030 option and download both the LPR driver and cupswrapper driver in .deb format to a convenient directory to install from. Continuing with the instl'n instructions in step #4 turn on the printer, then insert usb cable, but do not use the Ubuntu driver program gui, which will then start. It doesn't have an option for the DCP-7030 installation at least not at the time of this writing. Close out the gui and start up Terminal. Change to the directory, where the two drivers were downloaded and install the LPR driver using sudo dpkg -i --force-all brdcp7030lpr-2.0.2-1.i386.deb . Next similarly install the cupswrapper driver. Use sudo dpkg -i --force-all cupswrapperDCP7030-2.0.2-1.i386.deb . I tried installing only the cupswrapper driver at first and it wouldn't work, I expect because I hadn't first installed the LPR driver. After installing the LPR and then the cupswrapper drivers, enter (sudo not needed) dpkg -l | grep Brother and a list of installed printer drivers should show up including the DCP-7030. There was a command on the Brother site, which instructed me to restart the printing services with /etc/init.d/lpr restart. But this was not possible (no lpr file). /etc/init.d/cups restart was possible, but the printer wouldn't print. Finally got it working by restarting computer and it now works like a dream.

puntjuh 04-18-2010 10:24 AM

Good to hear that your printer is working now, quite convenient!

All times are GMT -5. The time now is 10:36 PM.