LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Hardware (http://www.linuxquestions.org/questions/forumdisplay.php?f=18)
-   -   ubuntu-12-04-2-on-apple-xserv-early-2008 (http://www.linuxquestions.org/questions/showthread.php?t=4175459585)

leblinux 04-25-2013 03:16 PM

ubuntu-12-04-2-on-apple-xserv-early-2008
 
I have at work several xserv doing nothing, and I want to install Ubuntu. I booted from the CD choose Efi and edited the kernel option to add nomodeset so it boots normally.

Then the kernel loaded fine until it hit the Ubuntu GUI installer which gave me unreadable Screen and colors, however I can see the mouse moving and if I hit enter on keyboard the installer jumps to other page in the installation but not readable at all. I tried kernel Options: video=vesa and other video modes But still same! any ideas regarding this?

**note that I tried ubuntu 12.10 server same thing happens when it reaches console mode.
Here is a video uploaded on youtube:
http://youtu.be/pmJRlc3DvMA

Picture too, on ubuntu 12.04/12.10 Desktop x64:

http://i.stack.imgur.com/xGaTq.jpg

guyonearth 04-25-2013 10:42 PM

What version xserve? Without knowing the hardware it's hard to offer any advice. The earlier ones used ATI x1300 graphics, the latest versions were Nvidia, I think.

leblinux 04-26-2013 01:39 AM

Hi,

It is the xserv 2-1 Xserve (Early 2008) here is the link: https://support.apple.com/kb/SP10

Built-in ATI Radeon X1300 PCI Express graphics board with 64MB of GDDR3 memory and single-link mini-DVI port; mini-DVI to VGA adapter included

leblinux 04-26-2013 12:37 PM

After ssh normally to the xserv, I installed xorg-driver-fglrx and xserver-xorg-video-radeon and rebooted with nomodeset, solved the console mode graphic problem. I can see everything clear, now I am installing the GUI apt-get install ubuntu-desktop to see if it works thru.

[UPDATES]

well now after installing the ubuntu-desktop it does not connect to the xserver so xserver-xorg does not start. I removed fglrx and here is a paste of my xorg.log

http://pastebin.com/y1zMVGYH

adamk75 04-26-2013 02:45 PM

The radeon driver will not work if KMS is disabled, which is exactly what you are doing by passing nomodeset to the kernel. If you don't use nomodeset, what happens?

Adam

leblinux 04-29-2013 11:49 AM

Hi Adam,

I removed the nomodeset and updated grub and rebooted, what was new is that it booted the Grub with the colored Menu and booted the system without a problem till it went to the console mode. Now logging in and typing: startx

gives this error in the xorg log.

http://pastebin.com/kw2pF3D3

And here is the output of dmesg:

http://pastebin.com/we5LsqCi

Thanks!

adamk75 04-29-2013 01:19 PM

Sorry, but you've clearly hit a number of different bugs here. All I can suggest is reporting the problems.

Adam

guyonearth 04-29-2013 03:13 PM

Have you tried making a layout and screen configuration and saving it in the x.org file? It looks like it's failing because it can't find or determine a configuration, maybe you just need to supply one. Have you tried using xrandr?

Sample:


Code:

Section "Monitor"
    Identifier      "External DVI"
    Modeline        "1280x1024_60.00"  108.88  1280 1360 1496 1712  1024 1025 1028 1060  -HSync +Vsync
    Option          "PreferredMode" "1280x1024_60.00"
EndSection
Section "Device"
    Identifier      "ATI Technologies, Inc. M22 [Radeon Mobility M300]"
    Driver          "ati"
    Option          "Monitor-DVI-0" "External DVI"
EndSection
Section "Screen"
    Identifier      "Primary Screen"
    Device          "ATI Technologies, Inc. M22 [Radeon Mobility M300]"
    DefaultDepth    24
    SubSection "Display"
        Depth          24
        Modes  "1280x1024" "1024x768" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
        Identifier      "Default Layout"
        Screen          "Primary Screen"
EndSection


leblinux 04-30-2013 10:15 AM

Updates,

As guyonearth suggested I created an xorg.conf file and rebooted! the Lightdm screen comes up!! Now I have a running X :) FINALLY! however when I login it quickly blink and shows back the lightdm login.
I went in to console and typed: startx, it opened Gnome desktop only no menus! I can only right click and create folder on the desktop.

*** Reminder that this is an ubuntu-server 12.10 and after I installed it, I did the apt-get install ubuntu-desktop. (555MB)

Is there anything else related to ubuntu-desktop to work?

Thanks!

guyonearth 04-30-2013 11:26 PM

Ubuntu (Unity) desktop and Gnome Desktop are not the same thing, which one did you install? I suspect the reason that there are no menus is because the server install doesn't install any of the scripts that create the menus, much like it didn't create an x.org either.

Things to try:

First, try
Code:

sudo apt-get -f install && sudo apt-get --reinstall install unity
Then, try
Code:

unity --reset
, followed by
Code:

unity --replace
also:

Code:

sudo apt-get install indicator-applet-appmenu indicator-applet-session
sudo apt-get install indicator-applet-complete
sudo apt-get install indicator-application indicator-session
sudo apt-get install indicator-power indicator-sound


leblinux 05-09-2013 05:58 AM

same nothing happened.

( I installed xubuntu-desktop and I logged into it without a problem) however my resolution is only 800x600 and I can't change it)


All times are GMT -5. The time now is 10:23 PM.