-   Linux - Hardware (
-   -   Trouble installing the Nvidia GeForce4 MX 440-SE driver in Open Suse (

Tomermory 04-19-2007 09:28 AM

Trouble installing the Nvidia GeForce4 MX 440-SE driver in Open Suse

I've just tried installing Google Earth, but it won't start (it begins loading and then sends me to the log on screen. When I log on, Google earth doesn't appear). After looking around on some forums it appears that I need to download the correct driver for my graphics card. I'd like to do this anyway as there are applications that won't run properly with the generic driver supplied by my OS.

The trouble is, that after I attempt to do this (via YaST) I get the black log on screen and the desktop refuses to start - I then have to run the update programme on the installation CD to get things back to normal again. I think these problems have been due to me not choosing the correct Nvidia driver, or not adopting the right procedure. Can anyone help me with this?
My graphics card is an Nvidia GeForce4 MX 440-SE and my operating system is Open Suse 10.2.

BTW - I have managed to get Google Earth running in the past but on a different OS - Mandriva 2007. Does it have a better generic graphics card driver than Open Suse?

Thanks in advance.

monsm 04-19-2007 10:03 AM

I am using FC6, but I did install Google earth the other day, works very nicely :)

I would recommend Nvidia's own driver from here:

There are some instructions on the page there. Good luck.

samstar 04-19-2007 01:11 PM

Yeah, recently Nvidia dropped support for old hardware in some of their drivers, and yast2 may not be getting you the right one. Go and get the driver from Nvidia that supports your card and make sure you have your kernel-source and kernel-syms installed before you use it.


Tomermory 04-20-2007 02:50 PM

Thanks for your replies. I've followed the instructions for Suse on the Nvidia site, but they don't make much sense to me, I'm afraid. x11-video-nvidia is easy enough because I find that in YaST - but I'm uncertain about the other one - I don't know which driver (or drivers) to select on the list. I'm not sure about my kernal flavour. When I do uname -r, this is what I get:

Also, can you tell me what kernel-source and kernel-syms are? As you can probably tell, I'm pretty new to this game!



reddazz 04-20-2007 02:56 PM

Download the latest legacy driver (version 1.0-9631) from the nvidia website and install that. You need to install a package called kernel-source before installing the nvidia driver. If you need more assistance, post back.

samstar 04-20-2007 03:39 PM

Just download what reddazz recommended. kernel-source contains the source code that was used to build your kernel. Just make sure you select in yast the one that matches your kernel version (

Nvidia drivers use the source code to create the nvidia kernel module, which is necessary for running the driver. In many cases, the kernel-syms package is necessary. It contains information necessary to build some kinds of modules, which is what the Nvidia installer is going to do for you.


Tomermory 04-21-2007 05:00 AM

I think I'm nearing a solution, but I want to check with you before I do anything (my former impatience has led to a number of problems in the past!):

1) Concerning the package called Kernal-source, where do I find it? A search on the Nvidia site reveals nothing, and it isn't listed in YaST.
2) On the Nvidia site there are separate instructions for Suse users:


SuSE users: please read the SuSE NVIDIA Installer HOWTO before downloading the driver.
Do I follow these instructions or just download and install the drivers manually? If I do follow these instructions, I need to install the driver from YaST, which Samstar suggests could provide the wrong version.

3) Here's something strange, and perhaps the reason behind my problems with Google Earth. This morning, I typed Nvidia in YaST and found that the following packages are installed:
  • nvidia-gfx-kmp-default (1.0.9755_2.6.18.8_1.ccj44-jen3-i586)
  • nvidia-legacy-gfx-kmp-default (1.0.7184_2.6_18.8_1.ccj45-jen3-i586)

The reason why this is strange is that I recently completely formated my hard drive, wiping everything off (including Windows :D :D ) but these are the two drivers I installed before I did this. I presume that these packages are not installed on the hard drive but in the graphics card itself, which would explaing why they resist the formating process.
Anyway, I'm tempted just to take them off - but I want to check with you first. They don't look to me like the ones that reddazz told me to install. If I do this, and then restart the computer, would I be correct in assuming that Suse will automatically switch to the generic drivers? That might correct the problem, although I'll want to update the graphics driver afterwards because the generic one doesn't allow me to run a number of applications.

Once again, thanks for your help.

samstar 04-21-2007 04:41 PM

That's very odd that you're not finding kernel-source in your yast. Make sure your install sources in yast are correct, and that they include a suse repository link that ends in /oss.

Another question. The kernel you're using, is that a default suse kernel, or did you compile it yourself from another source? The reason why I ask is because I do not recognize the "ccj45-default" extension. Where did you get it? Because suse 10.2's default repository doesn't list that extension. This is important because you have to have the exact same kernel source version installed for the nvidia drivers to install properly.

Your nvidia graphics card doesn't hold drivers in memory. The drivers may have been installed by default. Go ahead and use yast to un-install those, and make sure they are uninstalled by running nvidia-installer --uninstall (if that is wrong, sorry, just make sure you run the uninstall the right way).

Then reboot, etc., and install the 1.0-9631 nvidia driver. Use Nvidia's instructions, not the suse instructions.

If you found the source to your kernel, and if the installer can't find that source, then run the install with this option

sh ./ --kernel-source-path (path to the source)

reddazz 04-21-2007 05:04 PM

Did you search for "Kernal-source" (as written in your post) or kernel-source?

Tomermory 04-22-2007 03:03 AM

Great!! Fantastic!! That all went correctly! I managed to install the driver without trouble, and then tried Google Earth again and it worked! (although I had to re-install it first). Apparently, it isn't only Samstar that doesn't recognise my Kernel (and, yes, I did write kernAl - no problems with YaST after I spelled correctly :rolleyes: ) - the NVIDIA driver didn't recognise it either. It proposed an installation of a different kernel, which I accepted, and...voilą.
Thanks once again, guys! I guess now I can try the 3D desktop?? (or should I?)


Tomermory 05-11-2007 02:49 AM

I wrote the last reply about three weeks ago, and I wanted to complete this tread by explaining what happened afterwards, as this could be useful to others.

Well, the graphics card worked fine for a while: I was able to run things I had never managed to get working before, like 3D games etc. Then, just for fun, I tried the 3D desktop. This worked too - lovely. But then I noticed that applications that had worked well even before I had installed the driver were now painfully slow. I took off the 3D desktop but the problem remained. Nothing for it then but to re-install Suse...
Then I tried again. I followed the instructions for installing the Nvidia pilot, and once again it worked beautifully...until I did a system update, after which all I got when I switched on my computer was the black screen of death.:mad: Once again, I decided to reinstall.
I wasn't sure what the problem was, but I suspected the graphics card pilot was behind it all. So after my next re-install I kept the generic driver for a while and everything was back to normal. But I simply HAD to know if the graphics card really was the culprit (and, besides, I had had a taster of Vega Strike!), so I installed it again and, once more, it crashed after a system update. This time however, instead of re-installing, I ran the system update on the Suse DVD. While doing this, I got a message confirming that there was indeed a graphics card problem.
In the end, rather than re-installing Suse, I took the opportunity to put on a different distribution (Suse infuriated me with its endless updates which could take over an hour, and I found it very slow generally). This time I chose Ubuntu, the first Linux distribution I had ever tried but it isn't really good for beginners. After a very fast and easy install, I noticed a restricted drivers management tool (System-Administration-Restricted drivers management). My curiosity led me to run this, and there I found NVIDIA accelerated graphics driver with a little tick box to enable it. Seeing as the complete Ubuntu installation had taken me less than half an hour, I felt I had nothing to lose by ticking the box. Once done, Ubunutu identified, downloaded and installed the graphics driver (in seconds) and, after re-boot, everything worked wonderfully. And it still does...
So, it would seem that there is a problem with system updates and old graphics cards. If you have an old card, downloading and installing the driver could cause trouble after a new kernel is installed on your machine. And I certainly don't advise you to try the 3D desktop, impressive though it is. However, a switch to Ubuntu has worked for me (although I haven't dared try the 3D desktop yet), so it's possible that the difficulties you encounter depend not just on your graphics card, but also on the Linux distribution you use. Certainly as far as system updates are concerned, Ubuntu has the advantage of being very predictable, with a new update planned every six months.
Hope this is helpful to someone.

samstar 05-11-2007 11:24 AM

Frequently SUSE will come up with new kernel updates, and its possible for people to overlook the fact that yast or zen is currently updating their kernel along with the updates for other programs. Neither yast nor zen take the responsibility of reminding the user that a kernel update has been performed, and that the Nvidia drivers will need to be re-installed from scratch (or more accurately, the nvidia module needs to be rebuilt for the new kernel). So people reboot, expecting the system to load as usual, except it doesn't because of the missing module.

It'd be nice if the update manager could do something about it, like compile a new module for the new kernel, or copy the module to the new kernel's modules (not sure if that would work, though we're not talking about a totally new kernel, just an updated version of the original).

So to all, just remember to re-install the nvidia module, or the whole driver if it's easier for you, the same way you did the first time, after you update the kernel.


Tomermory 05-12-2007 02:07 AM

A very good point Samstar. I'll certainly remember that when I update Ubuntu. It's probably also worth pointing out that when you do a system update via the DVD (I'm talking about Suse here), a new kernel will probably be installed and that you simply won't be able to update your graphics driver before the system re-boots. This could well lead to difficulties for people with old graphics cards who have installed the accelerated graphics card driver. Probably best for them to do the system udpate via YaST in a normal session (ie, not from the DVD) because then they can re-install the driver before they reboot.

All times are GMT -5. The time now is 05:55 AM.