LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Total system freeze on ATI 3D driver enable (https://www.linuxquestions.org/questions/linux-hardware-18/total-system-freeze-on-ati-3d-driver-enable-608579/)

wdingus 12-22-2007 11:28 AM

Total system freeze on ATI 3D driver enable
 
MSI Platinum P35 mobo with 2.6Ghz Dual-Core, 4GB of PC2-6400 RAM and a Sapphire 2600HD Pro ATI PCI-E video card.

Installing Fedora8 (or Ubuntu 7.10 which I also tried to make sure it wasn't just a Fedora thing) works fine. The generic VESA drivers are installed and the display looks good at 1280x1024, albeit non-accelerated.

Downloading the driver from ati.com and installing it results in an utter system freeze the instant it's activated. Can't even ping the NIC from another machine, it's dead.

In Fedora I tried both installing the driver from ATI and manually installing as well as enabling the Livna/RPMFusion repo and allowing it to. For Ubuntu I also tried both the stock driver from their site as well as enabling the Ubuntu-provided version. Allowing Ubuntu to take care of everything related to enabling it at least didn't totally lock the machine, it tried enabling it and when that failed came up with a generic driver. Booting Fedora with it enabled definitely kills it though, no ALT-F1 or any other type of input.

Ideas? Hardware-wise everything is pretty much stock, BIOS "fail-safe" settings, etc...

Thanks!

wdingus 12-23-2007 10:03 PM

Nothing?

I've spent a bunch more time on this and still nothing... Here's a clean log of an attempted "startx" and subsequent lockup (/var/log/Xorg.0.log). Almost 1000 lines in the log file so it has time to do a lot of things and log a lot before freezing at least...

LOG

Uncle_Theodore 12-23-2007 10:20 PM

Some people advise to put the following lines into /etc/X11/xorg.conf, in the Device section, right after the "Driver fglrx" line

Option "KernelModuleParm" "locked-userpages=0"

Also, it might be a good idea to install an older version of the drivers, from the ATI site.

wdingus 12-24-2007 10:26 AM

Thanks, I've now tried that as well as going back to the 8.41.7 driver version. No joy either way.. With the older driver at least the box isn't totally killed, screen is blank and won't come back to life no matter what (no CTRL-ALT-BACKSPACE for instance) but CTRL-ALT-DEL is still responsive and will reboot without having to smack reset at least.

Thanks...

PS. Log file from attempt with older drivers: LOG2


All times are GMT -5. The time now is 11:44 PM.