LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   Though set UNMUTE using alsamixer, my soundcard still doesn't work,WHY? (https://www.linuxquestions.org/questions/linux-hardware-18/though-set-unmute-using-alsamixer-my-soundcard-still-doesnt-work-why-295363/)

chuanweizuo 02-27-2005 01:29 AM

Though set UNMUTE using alsamixer, my soundcard still doesn't work,WHY?
 
Information:
1. Linux distribution: Redhat 9(shrike 2.4.20-8)
2. Mainboard: ASUS P4B533-X(intel 845E chipset)
3. Soundcard: integrated by the mainboard, detected by windowXP as:SoundMAX integrated digital audio, and detected by Linux as:Intel Corp, 82801DB AC'97 Audio
4. The sound box has no problem, and so is the *.wav music file I used to test.

What I've done:
1. I've installed the alsa-driver-0.9.6,alsa-lib-0.9.6 and alsa-utils-0.9.6.
Then, I run "modprobe snd-intel8x0" and no error information was given, so I thought it was OK. I could even run "alsamixer" and I can saw its graphic configuration interface, I set every chanel UNMUTE. After that, I run "xmms" and played a *.wav file to test, only to find the soundcard still doesn't work.
2. I click the Redhat9 main menu--->system settings(not quite accurate, for i'm using Chinese system, I just translate the Chinese words into English)-->soundcard detecting. An error information
was given as "not compatible" or something like that.
3. I run "lsmod" in the console, the modules given out are the very ones I added in the file /etc/modues.conf. This shows no problem.

Conclusion:
It appears that I've drived my soundcard properly. Actaully, it doesn't work authough I SET EACH CHANEL UNMUTE.

Anyone encountered the same problem as I did?

Thank you for your attention and
Hope for your replies!

Ovalteen 03-04-2005 09:27 AM

I guess you might have already solved this, but if not try doing this:
1) Open the XMMS menu, go to Options, then go to Preferences.
2) Go to the Audio I/O plugins tab, then where it says Output Plugin, select either OSS Driver or ALSA something or other (I use OSS Driver with ALSA and it works fine). If it says Disk Writer Plugin, that's what the problem is. XMMS is trying to play to CD-ROM instead of your sound card.
3) Click Apply, then OK, then try playing something.

Hope this helps.

Cheers

Ovalteen


All times are GMT -5. The time now is 03:16 PM.