-   Linux - Hardware (
-   -   System Time Getting not correct getting slower (

flatstan 08-20-2009 03:32 PM

System Time Getting not correct getting slower
The time on my system - SUSE 10.3, Asrock K81639 Mobo, is getting slower.
As this is normaly due to a failing battery I have changed the battery twice for new ones.
This has no effect though and currently the time is losing about 24hrs each day, I reset it each day on both the desktop and on the BIOS.
Does this mean the Mobo is failing or can there be another reason, the problem started about 2 weeks ago. Any ideas welcomed, thanks.

kilgoretrout 08-21-2009 09:43 AM

If that's your only symptom, I doubt that your MB is going. The battery only helps the bios retain its setting, like the time, when power is removed. If you're losing time with the system powered up, it's a software problem. It's not clear from your post whether you're gradually losing time during the day as you run or only after powering off for the day and on restarting the next morning. If it's the former, it's definitely a software problem.

catkin 08-22-2009 05:00 AM


Originally Posted by kilgoretrout (Post 3652354)
If you're losing time with the system powered up, it's a software problem.

Is that correct? AIUI there is a hardware clock.

kilgoretrout 08-23-2009 11:35 AM

It is a hardware clock but it can be affected by software. For example,when you sync your system time setting through an ntp server you are resetting the hardware clock with software. Certain games can effect the system time settings as well in both windows and linux. The usual effect is you see the system time run slow after playing certain games. On the hardware side, overclocking can effect system time as well but that doesn't appear to be an issue hear.

flatstan 08-24-2009 03:43 PM

System Time Slow
I'm sorry I did not give enough information, at the moment it seems that the time given by BIOS is OK, just the SUSE time is faulty. I will watch for a few days & get back. thanks for the help.

J.W. 08-24-2009 05:32 PM

Could it simply be that you have selected an incorrect time zone for your location, thus creating the appearance that the clock is losing time? One time my system suddenly seemed to be off by about 16 hours or so, and it was because I (somehow) managed to change my timezone setting to one on the other side of the earth. Dunno exactly how that happened, but once I reset it to the correct zone, all was well

flatstan 08-26-2009 03:17 PM

System time getting slower
Thanks people, after watching more carefully I find :-
The time zone is correct, Europe-UK, The system time shown on the BIOS remains correct. SUSE time remains correct whilst SUSE is running, I've only checked this for a couple of hours, but it stayed correct within a few seconds during this time. When the system is turned off for about a day then restarted, the BIOS time shows correct, but the SUSE time is about 22 hrs slow.
As you say it seems that the problem is software related, I have not installed any new progs in the last few weeks cept updates, I do not play games & only use the box as a home/office.
Any ideas as to how I can cure this prob will be appreciated, thanks.

Myiagros 08-26-2009 03:42 PM

You could sync to an NTP server in your area if you can find one so when your computer reboots it automatically updates the time with the server.

kilgoretrout 08-27-2009 01:00 PM

That really sounds like suse is resetting to a different time zone after powering up from a shutdown. If it is always a 22hr difference, then that's almost surely what is happening. Try shutting completely down, i.e. not a restart with an automatic reboot. And then boot back up after a few minutes. See if the time is resetting to the same offset.

flatstan 08-28-2009 01:57 PM

Time Slow
HI, thanks people. Yesterday on booting I found that the BIOS time was about 24hrs slow, SUSE time was about 4days slow. I reset them both to the correct time, I also synchronized with, a time server recommended for England . Suse time stayed about correct for the 4 hours I was using the box.
Today on booting, BIOS time was correct, SUSE time was 38hrs slow. I corrected both of them, I did not synchronize with a time server.
As suggested,I shut down completely for 2mins exactly, then started up again. BIOS time was correct, SUSE time was 6mins slow, so it seems that BIOS time is OK, but SUSE time is losing considerably whilst the box is off, and synchronizing with an ntp time server makes no difference.
This is really a puzzlement, this has happened without any apparent reason, any more ideas as what is going on ? Thanks.

michaelk 08-28-2009 03:30 PM

My curiosity has has been aroused...

BTW when the computer is off so is the system clock or what I assume you refer to as the SuSE clock so it is impossible for it to lose time.... When the computer is powered on one of the boot up sequences is to set the system clock to the hardware clock. There is a drift correction factor which might be messed up so to speak or some processor interrupt is not working correctly which could cause it drift or not be synced to the hardware clock. When the problem was first noticed had you made any changes i.e BIOS configuration changes, kernel upgrades, install any new games or doing anything different that is putting a big CPU load on the system etc.
Running ntpd should fix the drift correction factor problem over a period of time.

flatstan 09-01-2009 02:01 PM

Time Slow.
Thanks michaelk, no I have not done anything unusual, I don't play games, I have not changed any settings in BIOS cept to change the time & date after the prob' started. Thanks for the links, I'll try ntpd. rgds.

flatstan 09-01-2009 02:24 PM

Hi michaelk, I checked my YAST & apparently I have an old version ntp or xntp on my system, I have tried ntp & xntp in a console but error msgs result, how do I run this program ? thanks.

michaelk 09-01-2009 06:08 PM

This might help:

flatstan 09-02-2009 04:19 PM

Thanks michaelk, I will give this a try, rgds.

All times are GMT -5. The time now is 03:44 AM.