LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   System Freezes (https://www.linuxquestions.org/questions/linux-hardware-18/system-freezes-488785/)

tomatoefish 10-02-2006 02:10 PM

System Freezes
 
Hi!

I am running Open Suse 10.0 on a Thinkpad R40. After working with the laptop for a couple of hours the system starts to stop erratically for a few seconds. The keyboard and mouse do not respond any more. Music stops playing. The screen is not updated anymore. Afterwards a couple of seconds the system continues to work until it stops again. Shaking the laptop seems to help.

I already tried a couple of things besides shaking :-)

1) Check the memory. (Try with just one memory bar at a time. Run a memory test. ...). So the memory are OK.
2) Run a system diagnosis to no avail. So I hope the harddisk is all right.
3) Monitor the system temperature which stays constantly below 47C. So at least the mainboard is not overheating. However the harddisk seems to get a little hot. The fan does not turn on.
4) I get the same freezes in the BIOS.
5) Removed the windows partition and reinstalled OSS 10.0 without solving the problem.

I suspect a failing mainboard, but have no idea of how to track down the error. The dmesg does not change during the system freezes.

Any suggestions appreciated!
tomatoefish

jailbait 10-02-2006 02:18 PM

This problem sounds very much like an overheating problem. I suggest that you run a test by running with the cover off and an external fan blowing on the CPU.

"The fan does not turn on."

Does the fan ever turn on? Check to see if the fan is working.

-----------------
Steve Stites

tomatoefish 10-02-2006 02:28 PM

Thank you very much for the reply.

Under heavy usage the fan turns on. So it is not broken. Might be blocked.

I tried to increase the cooling by putting the laptop on a metal plate to cool it. However the freezing persists.

I tried to open up the laptop before, without success. How I miss my desktop sometimes :-)

To be a bit more precise. The laptop unfreezes when I push slightly on the casing to the left of the touchpad. So I push on the harddrive and the memory. Sounds funny, but googling a bit I am not alone with that problem.

Thanks again!


All times are GMT -5. The time now is 06:24 PM.