-   Linux - Hardware (
-   -   Suspend vs. Visualization (

taylorkh 06-18-2010 03:42 PM

Suspend vs. Visualization
Here is the latest in my saga of me vs. Suspend in Utuntu.

Dell Studio XPS 8000 desktop
i7-860 CPU
swap area set to 9 GB (because I was experimenting with hibernate)
nVIdia GeForce GT220 1 GB
Ubuntu 10.04 64 bit, all patches, nVidia-current 195.36.24

So I was poking around in BIOS and looking at CPU Features. I have also a problem with my VMWare machines sucking up a core or 2 at 100% after suspending and waking the host. Just for the halibut I Disabled CPU Visualization. My VMWare XP guest now starts up a lot faster! (?)

and I have discovered... If I do a suspend of the host BEFORE starting and LOGGING IN to a VM it seems to work great. I can wake the host and am presented with the locked screen dialog asking for my password. I have done about 20 suspend/wakes with no problems. So far, so good.

Upon further testing I find that I can start a VMWare or Virtualbox XP guest machine and still suspend/wake - at least so far with a limited number of tries.

Most importantly, if I log into the guest (VMWare or Virtualbox) I find that suspend/wake fails 100% of the time. By fail I mean that the host suspends but when I attempt to wake it I find that I am logged out of the host and all programs which were running at suspend time are no longer running. Firefox restores the previous session indicating that it was shut down incorrectly or unexpectedly.

Let me post this and move onto my next experiment - logging out of the guest before suspend or shutting down the guest before suspend.

Any advice or comments appreciated.



rweaver 06-18-2010 04:24 PM

In my experience this isn't unusual, I've had significant issues suspending/hibernating while there are running virtual machines that I'm actively logged into also (with vmware, never tried it with virtualbox), I think a lot of the issue comes from the fact that the guests never get the operations completed before needing to shutdown and it has detrimental effects when they come back up.

taylorkh 06-19-2010 03:59 PM

Thanks for the reply rweaver. I really thought I was on to something. I did several suspend/wake cycles and seemed to have pinned the issue to being logged into a VM. Then I shut down the host completely, powered it back up, started a VM, logged in and back out of the VM and then tried the suspend/wake. It FAILED :doh: I was back to the host login.

So I did not do any more experimentation last evening. Today I needed to run a Ubuntu 64 bit VM and VMWare told me it could not be run without virtualization being enabled in BIOS. I re-enabled it BIOS, did my VM testing then left it enabled.

I tried running my XP VM, logging in and then doing a standby. This closes the VM in VMWare and saves the state. Once suspend/wake worked and the next time it did not. I seem to be having success with suspend/wake if I completely shutdown the VM before the host suspend. What a pain.


rweaver 06-22-2010 12:29 PM

That would largely match up to my expectations of it at this point. It's one of those finer details they just seem to have not quite ironed out perfectly.

All times are GMT -5. The time now is 10:08 AM.