LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 05-30-2004, 10:43 PM   #16
NightStarLWR
LQ Newbie
 
Registered: May 2004
Posts: 3

Rep: Reputation: 0

I did a clean install of SuSE 9.1 from DVD today, I did select "All of KDE"

Hit google when I noticed the exact same symptoms with my Audigy, no sound but it 'looks' like it works, driver loaded, etc.

Saw the bit about kdemultimedia3-mixer, and running alsaconf.

Here's what I did that seems to have fixed mine:

Popped open terminal, su to root, alsaconf, just ran through it, all the default choices seemed acceptable.

Immediately XMMS starts playing sound, KDE system notifications work, everything works.

I then removed (via YaST2) the kdemultimed3-mixer package, then I rebooted.

When the system came back up, I remapped the SMB share my MP3s are on, and loaded XMMS, and it plays fine.

If it matters, the system is:

Athlon XP 1700+
Shuttle AK31A (v3.1, KT266A)
512MB of PC2100 (random brand)
SB Audigy (OEM)
ASUS V8420 128MB
Seagate Barracuda 40GB ATA100
 
Old 06-20-2004, 12:37 PM   #17
optimalprimer
LQ Newbie
 
Registered: Apr 2003
Location: Nevada, US
Distribution: Suse 9.1
Posts: 25

Rep: Reputation: 15
Kmix isn't the problem. It actually contains the gui frontend for speaker controls other than just the master. I stated out w/ no sound, using an Audigy 2, and made sure all alsa tools were installed. Next, I went into the control center, Sound & Multimedia, Sound System, Hardware tab, and selected the audio device from "autodect" to "Advanced Linux Sound...". Next I ran aslaconfig from a terminal. Finally, I ran Kmix, clicked Advanced in the lower-left corner, and made sure "3D Control" and "Audigy Analog" were selected. From there, I turned the volume up on pretty much everything (just to be safe), except for the master. Voila! Sound in Suse 9.1 using an Audigy 2. Haven't tried xmms, but I've read you have to make sure to select the ALSA pluging from its right-click menu...
 
Old 06-20-2004, 03:48 PM   #18
NightStarLWR
LQ Newbie
 
Registered: May 2004
Posts: 3

Rep: Reputation: 0
I only deleted the mixer package because someone else (in another thread I think) had suggested that it might be making some configuration change that was a problem for Audigy users.

I must not use that program anyway, because I didn't notice anything missing after I deleted it.


As for xmms, after I got the sound working, I left its configuration at default (ie the Autodetect plugin).

I'm just glad the fix was relatively painless, whatever the proper fix is.
 
Old 06-21-2004, 12:01 PM   #19
optimalprimer
LQ Newbie
 
Registered: Apr 2003
Location: Nevada, US
Distribution: Suse 9.1
Posts: 25

Rep: Reputation: 15
The advantage of having kmix is the control of other speakers (othere than just the main). So, if you want more than two speaker support, you might need kmix.... fyi.
 
Old 06-21-2004, 06:39 PM   #20
NightStarLWR
LQ Newbie
 
Registered: May 2004
Posts: 3

Rep: Reputation: 0
mine seemed to be playing out of all four, and that's all i have, so it already works the way I want, but but others with more complex systems I can see the need.
 
Old 06-27-2004, 04:39 AM   #21
hein
LQ Newbie
 
Registered: Jun 2004
Distribution: suse 9.1
Posts: 1

Rep: Reputation: 0
Yes, optimalprimer is right. The problem lies with a simple mixer setting in the alsa mixer. I had the same problem but found a solution on the internet:
Quote:
I had the same problem with my Audigy 1. Since it's a different card, I
can't swear this will work, but it's something to try.

Open up a console window and run "alsamixer". Maximize the window so you
can see more of the sliders at once - there are several off to the right
that aren't visible until to scroll over to them using the arrow keys.

There's one slider called "analog mix" that needs to be up at a reasonable
level. To the right of that, there's one called "Audigy Analog/Digital
Output Jack" that needs to be OFF. With this slider selected, press the
"M" key to mute it. This should give you your sound back, assuming the
rest of the sliders are set appropriately.
The reason that for some of you deleting the kmix mixer package worked, is probably that that slider just wasn't there anymore to mess things up

Anyway, a bit late for this reply maybe but i thought i should mention it.
 
Old 06-29-2004, 01:10 AM   #22
mindhammer
LQ Newbie
 
Registered: Jun 2004
Location: Singapore
Distribution: SuSE Linux Personal 9.1
Posts: 2

Rep: Reputation: 0
KMix solution

Hi, I had exactly the same problem you described.

The way solved it was to open KMIX (not KAMIX) and toggle the Analog/Digital Output Jack . You need to check the "Advanced" box of KMIX in order to do this.

So maybe you can also solve your problems using KMix, too.

I've also set KMix as my system tray volume control instead of KAMix.

Hope it helps


Last edited by mindhammer; 06-29-2004 at 01:20 AM.
 
Old 06-29-2004, 07:10 AM   #23
skunkcabbage
Member
 
Registered: Aug 2003
Location: Oxfordshire, UK
Distribution: SuSE 9.3 Pro/SuSE 10 Eval
Posts: 64

Rep: Reputation: 15
Hi - is there a common link here?
Kernel 2.6.x, SuSE, VIA onboard sound etc?
 
Old 07-12-2004, 05:01 PM   #24
robamler
LQ Newbie
 
Registered: Jul 2004
Distribution: SuSE 9.1
Posts: 1

Rep: Reputation: 0
You have problems with a VIA onboard sound card?
I had some troubles getting VIA AC 97 to work but I finally got it by
- opening yast2 --> hardware --> sound
- setting the option "ac97_quirk" of the sound cart to "2"
- when exiting yast2 there must be a question whether the sound system shall be restarted. restart it and exit the sound configuration tool of yast2 (this is important).
- running alsamixer and unmuting and raising the following channels: "Master", "PCM", and "VIA DXS" (the latter won't be visible on startup so you have to scroll there first.)

The only problem I have now is that I always have to set these settings again when I restart my machine. I'm currently trying to find out how to access the sound configuration tool of yast2 by command line, so that I can do this automatically on every startup, but this seems to be difficult. Any hints are welcome.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
must re-run alsaconf to get sound fatman Debian 8 08-26-2006 05:37 PM
sound goes out after each reboot.(sb audigy 2 ze) gonus Linux - Hardware 2 02-23-2005 06:29 PM
sb audigy 2 ge no sound b4 or after alsa-conf gonus Linux - Hardware 0 01-22-2005 08:55 PM
Sound comes each time only when I run alsaconf. rsamurti Slackware - Installation 3 05-06-2004 06:54 AM
After using alsaconf, I lose sound on a reboot jeramy Slackware 2 01-11-2004 10:13 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration