-   Linux - Hardware (
-   -   Suse CUPS error: cups(File)DoRequest error:client-error-bad-request (

smdonelan 07-22-2006 10:43 AM

Suse CUPS error: cups(File)DoRequest error:client-error-bad-request
A few days ago I tried to print something to my USB printed and the printer happened to be powered off at the moment. The print failed and I don't remember the error that was printed at the time.

Today I noticed that the printer still doesn't work. I have tried clearing the printers queue via lprm. There is probably a simple explanation to what happened. Can someone help me get my printer working again? I don't have much experience with linux yet so please spell out any steps to try with command line examples.

From Yast, When I attempt to print a test page to the printer I get the following error:

An error occurred while communicating with the CUPS server while saving queue y2test. cups(file)DoRequest error:client-error-bad-request.

More info if it helps:
user@linux:~>lpstat -a
styluscolor740 accepting requests since Jan 01 00:00

styluscolor740 is not ready
no enteries

smdonelan 07-22-2006 09:02 PM

Problem Solved.

I logged into yast, deleted the old printer from the list and created a new one to replace it. It is working fine now.

jessjackson 10-14-2006 04:40 PM


I have had exactly the same problem with a USB connect Epson Stylus Photo 785EPX. But every time the printer is powered off, I have to go through the re-creation process again. Is there any "solution" that sticks?


timin 11-27-2006 11:10 PM

Thank you thank you thank you thank you....
....I would type it some more but I think you guys get the gist.

I've been troubleshooting a similar problem for, well, too long on our Linux LAN here at home. My sons using Suse 10.1 could no longer print to a Brother Laser served up from a Win2k server over our WiLAN. I tried just about everything but the suggestion of deleting the YAST entry and starting from scratch as you have suggested. I tried it tonight and your resolution worked flawlessly.

Thank you!

Now, how long do we all think the solution will stick?


smith_cc 04-17-2007 03:16 PM

This worked for me:
CUPS printer daemon saying "printer not ready" even there is no job running.: This rarely happened problem may be caused by configuration problems. Look at /etc/cups/printers.conf and see if "State Stopped" appears instead of the correct "State Idle". Make the the change and restart CUPS daemon.

Quakeboy02 04-17-2007 04:18 PM

Please try this for managing CUPS:


Electro 04-17-2007 07:46 PM

When trouble shooting CUPS, change logging to debug or debug2 in /etc/cupsd/cupsd.conf. Then restart CUPS. It should give you more information why it is stating "printer not ready". When it is working correctly, change it back to info (I think).

Use CUPS web manager to add printers, remove printers, stop jobs, view jobs, and many other features and settings.

All times are GMT -5. The time now is 06:23 PM.