LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Hardware (https://www.linuxquestions.org/questions/linux-hardware-18/)
-   -   SUSE 9 CD/DVD media problems (https://www.linuxquestions.org/questions/linux-hardware-18/suse-9-cd-dvd-media-problems-126628/)

GTB1964 12-17-2003 09:15 AM

SUSE 9 CD/DVD media problems
 
I have Packard Bell (Pulsar 510) Pentium III, and have decided I'd like to defect from Microsoft and put Linux on it instead. I've installed SuSE 9.0 with absolutely no problems during installation. However when I come to use the cd (Optowrite 52x) or DVD (Microstar 16x) both players do not recognise that there are any disks loaded.

I've done some searching on the web, and after several days come up against a brick wall. I asked a friend of mine who's used Linux quite a lot to take a look but he's baffled too.

As a Linux newbie I don't know what to do next. I don't want to remove Linux and go back to Microsoft, can anyone please help?

Pedroski 12-17-2003 09:58 AM

Did you mount them?
Red Hat has automount, but I don't know if SuSe does.
I'm no expert either but try, in a terminal
mount /mnt/cdrom. Might get your CD going
RH using KDE can on a right mouse click insert desktop links to cdrom or dvdrom, so then when you right click the icon cdrom, there is a menu which includes mount, saving terminal work. Otherwise try man cdrom, or man anything you have probs with, in a terminal of course.
Good Luck

Area51 12-17-2003 11:38 AM

On the desktop you should have 2 icons for your drives...........have you left clicked on them?

If you have a music cd (not mp3) in a drive it should just open a player to play it,all others have to be clicked on the icons

GTB1964 12-18-2003 04:10 AM

Thanks for your help.

I went into YAST and clicked add on the cd and dvd which added mount points. Both the dvd player and cd player now recognise data cds.

The dvd refuses to play dvd's though. I got an error message telling me that Xine can't play dvd's due to missing codecs, and that I should check out http://portal.suse.com/sdb/en/2003/09/xine_dvd.html, which tells me there is no legal dvd player that runs on Linux. My next port of call will be Xinehq! unless anyone out there has any better ideas?

I still have a problem with recognising audio cds. The dvd plays an audio cd but I get no sound, I'm gonna check the internal cables tonight, but the burner doesn't even recognise a disk has been inserted when I put an audio cd in.

GTB1964 12-22-2003 04:14 AM

Fixed - thanks
 
I now can play audio from my dvd player, although still can't from the burner (but I'm not that bothered about that). Visiting Xinehq sorted the dvd player problems. Thanks everybody who helped.

sasquash 12-26-2003 03:15 PM

Hey GTB1964,
how did you get SUSE 9 to play dvds?

GTB1964 01-08-2004 03:02 AM

Hi Sasquash

Sorry for the delay in replying, I've been away on hols, (no net connection).

I gave up trying to do the ./configure, make, make install routine. It didn't work, and as a newbie I didn't have the knowledge to fix it, just spent lots of frustrating hours trying!!

In the end I visited www.xinehq.de, clicked downloads, nightly releases, pre-compiled rpms.

Just save all the required rpms to your pc and install by clicking on them.

RPMs are definitely easier for a newbie (like me) as they do everything for you, even to putting xine on the menu, or you can create a launcher on the desktop and just point it at xine.

Xine expects your dvd player to be /dev/dvd, but if yours is defined as /dev/cdrom or /dev/cdrom1, open a terminal, log in as root, and issue:

ln -sf /dev/cdrom /dev/dvd

this creates a link from cdrom to dvd.

Hope this helps.

sasquash 01-14-2004 11:29 AM

which rpm did you download?

GTB1964 01-15-2004 06:05 AM

I've just reinstalled my pc with SuSE 9 professional (instead of personal)and done things a little differently to get the dvd to work. I was having troubles installing xine-ui so I've used Kaffeine as the front end, which works fine.

I'm using a Pentium 3 and a Pentium 4 pc, the following worked for me, but you may need to download different rpms if you're not using either of these.

Do the following:

Log in as root
start YAST
click Install and remove software
type xine in the search box, enter
you'll get a list back of what's installed as default with SuSE. The list should include kaffeine, kdemultimedia, xine libs etc, it all needs removing.
click on the check boxes 'til each entry has a trash can next to it,
do not trash the xinetd file, this is part of your system!
click accept, and all the stuff will be removed.

in konqueror go to: http://cambuca.ldhs.cetuc.puc-rio.br/xine/

download to the desktop:
w32codec-0.52-1.i386.rpm
libdvdcss-1.2.8-1.network.i386.rpm
libxine1-1_cvs-031230.i686.rpm

click on each file on the desktop (in the above order) and click on the install with YAST button

in konqueror go to: http://packman.links2linux.de/
click multimedia
click xine
click kaffeine
click kaffeine-0.4-0.pm.1.i686.rpm

it takes a minute or two to copy

click on install with YAST

You should now be able to launch the main menu, under multimedia, video player, click on kaffeine.

When it loads, put a dvd in the drive and click on play, dvd, from the kaffeine menu.

Good luck.

avonsydow 01-21-2004 03:13 AM

Hi,
I also use Suse 9.0 and have the same problem.
I followed the instructions above but it did not work. While I was installing the items suggested above, I also had to install:
libxine1 Version: 1-0.rc0.7mdk
termcap Version: 2.0.8-781
What I installed before I could install
xine-ui Version: 0.9.23cvs-040116
I then installed
kaffeine Version: 0.4-0.pm.1
but a got the following message

Can't init Video Driver! (auto)

I would appreciate any help

GTB1964 01-21-2004 05:17 AM

Have you tried the xinehq.de website, and downloading the rpms there? It has really good instructions.

I've just installed another distro, Xandros 2.0 on a pc, and that comes with a working copy of Xine. All I had to do was install libdvdcss.

avonsydow 01-30-2004 02:20 AM

Some progress!
The CD is working (with Xine-ui.version 0.9.23 and Kaffeine 0.4)
I downloaded all rpms from http://packman.links2linux.de/ rather then http://packman.links2linux.de/

...but the DVD is not
I created the symbolic link /dev/dvd and confirmed that xine config, vcd, points to /dev/dvd but I keep getting a message " Error: No VCD, or wrong path to device"
Any clues?

GTB1964 01-30-2004 03:01 AM

Only things I would suggest are:

1. Does your dvd player support vcd (video disc)? (Do you not play dvd's by clicking on the dvd button? - not on the vcd one).
2. Have a look at the preferences in xine, there are some paths there which are configurable.
3. Is there a plugin on the xine site for vcd's?
4. Are you sure that the mount point you are symbolically linking to is correct for your system?

Pedroski 02-01-2004 11:46 AM

I had trouble with DVD. But if I navigate under the playlist, using the xine UI, and seek out the individual .VOB files, it plays them fine. The DVD is a BBC collection "Red DWarf", hilarious, but after the warning intro about copying, it hangs itself, wont proceed automatically, but if I do the above, works fine.
Do you know if cdrecord can handle copying DVDs?

GTB1964 02-03-2004 04:18 AM

Not sure, K3b does dvd burning


All times are GMT -5. The time now is 06:14 AM.